Home > Lightroom & Photoshop Discussion > Lightroom Classic CC for Windows & Mac (folders) > Latest LR CC cannot display compressed Fuji X-T2 raw files

Latest LR CC cannot display compressed Fuji X-T2 raw files

  1. Hi,

    Just upgraded to the latest LR (I was never told on my iMac El Capitan that a new version was available) and suddenly LR will not show me my Fuji X-T2 images when importing them into LR. If I click individual images, they show, and they also import without a hitch, but they won't display (see screenshot). There is no such problem with uncompressed raw files.
  2. I'll check again, but I've not had problems with compressed XT2 files on either my PC or Mac.

    It may be that the compressed file doesn't contain a preview image, but that would surprise me.
  3. Most people have only had this camera a few days!

    I just checked and I was getting previews for both types of raw file. The first few here are uncompressed, the last ones compressed. This was also on El Capitan with Lr 2015.7

  4. Yes, but what version of LR? Sorry, not a stupid question, I did see your 2015.7 version but when I upgraded yesterday I went to something like 2015.7.6 if memory serves me right. Unfortunately, LR does not actually display that "sub"version number, at least I cannot find it.

    PS. System Info reads Lightroom version: CC 2015.7 [ 1090788 ]
  5. Also Lightroom version: CC 2015.7 . I'm pretty sure Adobe initially referred to this version as 2015.6.7 on this page.

    I've messaged someone else who has an XT2 and pointed him to this post. But I can't think of any camera setting that would cause your problem. Is El Capitan up to date? Though I thought Import would use the embedded preview in the file.
  6. May be it is time to restart the computer and see if this solves it.
  7. Sophisticated solution!
  8. I know ... my answer to all problems, computer related and others ...

    I did and it did not, as the screenshot shows. The last two are compressed, the one before it was not; no other setting was changed in the camera. Could it be a card (a SanDisk Extreme Pro) issue (hard to believe) or a card set-up problem (I use one card for raw, one for jpgs)?

    Screen Shot 2016-09-23 at 17.47.51.jpg

    Curiouser and curiouser ...
  9. I'm on Yosemite in the house, so I can't speak to El Capitan. Perhaps in the studio when I get back there. In the meantime, I see the preview of a test image in Import and it loads just fine. I'm using the newest CC version that came via the cloud updater. I was trying to see if there's a way to show if a file compressed on not, but I don't see it in Metadata on a quick peruse. The file is 23.4Mb vs the normal 50Mb uncompressed.

    It could be an Apple issue with previewing Raw files. Doesn't LR use the Apple preview mechanism in Import, johnbeardy?
  10. That was on my mind when I asked "Is El Capitan up to date? Though I thought Import would use the embedded preview in the file."
  11. Here's a file if you want to try it. Dropbox - DSCF2023.RAF Just a colour checker and random stuff on my table.

    My original purpose for this was for someone to test C1 9.3 for compatibility. It doesn't work with it as it turns out.
  12. Thank you for the file, that helped me come to grips with the problem. After downloading your file, it showed up fine in the LR import window. So I thought that perhaps it may have had something to do with the card (after it has been read on a Mac) and copied the two files that could not be previewed from the card to the Mac, and low and behold, they now show up fine too.
  13. So I formatted the card, took a few more pictures and tried to import those into LR. Same problem. I copy the files to the harddisk, they show up fine in the import window. I guess I will try a different card next.
  14. I did and they still do not show up using a different card. So perhaps the problem is a LR one after all. BTW, I am on the latest version of El Capitan. John, when you showed your compressed files were they still on SD (looks like they were); are you absolutely sure they are compressed, and what brand SD disk are you using? I tried SanDisk Extreme Pro (95 Mb/s) and an Elecom 30MB/s.
  15. Have you tried importing the image file into LR directly from the camera card in a card reader? What software are you using to copy the images to the Disk before i porting into LR?
  16. Yes, they were on the card and I shot them deliberately for this test, so I am 100% sure the last group was compressed. The card is a Lexar which has been formatted in the camera, and I've just imported a series of files from this morning, all raf and around 22-25mb on disc. Again, I could see the thumbnails in the Import dialog. So I can't see why it should be fine for me and not for you.
  17. Haven't tried a card reader because I haven't got one. I simply used Finder to copy the files from the card.
  18. I just updated LR on my MacBook Pro and tried the same operation there with exactly the same results (see below).

    Screen Shot 2016-09-24 at 19.29.36.jpg
  19. Mysterious. I am running out of things to try.
  20. On the Fuji site I got a response from another user who confirmed my impressions and findings:

    "Compressed Raw files from both the X-Pro 2 and the X-T2 no longer display as thumbnails in the import dialogue since the upgrade to Lightroom CC 2015.7 (Build 1090788).

    If you double click on the thumbnail it does display the image and they import correctly.

    I can definitely confirm that the thumbnails were visible before this upgrade.

    I am pretty sure that this is an Adobe problem and nothing to do with OSX and card"
  21. Anyone any idea if this problem will be addressed soon by Adobe?
  22. Assuming it's their problem, which I don't think is proved, I wouldn't expect it would be fixed until the next dot release which might be a couple of months.

    Is there anything unusual when you scroll through the pictures in the camera? What I am thinking is that one might expect to see icons like these if the camera hasn't embedded a thumbnail in the RAF file. However, I don't think I've seen any camera setting that might cause that to happen. I think you're going to go looking for others with the same problem (see Fuji X T-2, Lightroom, and compressed files) and see if you can identify a pattern.

  23. Sorry, I should have read the whole thread. Yes, using import Files instead of Devices is a work-around. Can't imagine it has anything to do with the cardreader, since these files are recognised if they have been saved as uncompressed files.
  24. Then might it be a firmware thing?

    By the way, the big danger of that workaround is that it would allow you to import the photos while leaving them on the card. Format the card, and it's goodbye to the pictures (or time for ImageRescue).

  25. PS Do you see these compressed RAFs' thumbnails in ImageCapture? What about when you examine the card using Finder?
  26. I am experiencing this issue just in the past week after doing a fresh install of the OS on my iMac . I was having no problem viewing the previews of my compressed raw X-T2 files until I upgraded my Mac to 10.11.6 from 10.9.5. In the process, I removed and reinstalled Lightroom, and since I'm on the CC version, I got the latest - 2015.8.

    I can assure everyone that this is not a hardware issue since none of mine changed - it's all software that changed. Unfortunately, since I changed two things simultaneously, I don't know which one caused the issue.

    I'd sure like to get it resolved. Until then, I have to blindly import everything, then delete out what I would have simply not imported when I could see them in the preview.
  27. Having recently changed from Canon to a Fuji Xpro2 I can confirm that compressed RAW files do not display as thumbnails on my system until downloaded from the card whereas uncompressed files do. As I always download all image files I don't find it a problem although it did give me a bit of a fright when it first happened as I thought that they were somehow corrupted or incompatible.
  28. I recently updated my Mac to Sierra and now the problem does occur. I have reported the bug to Adobe.

  29. Adobe released Lightroom 6.9/CC2015.9 today.

    This issue should be corrected in this release. Please give it a try and let us know if you see any further issues.

    Complete information about this update can be found at the Lightroom Journal: Lightroom CC 2015.9 now available

    If you don’t see the update in your Creative Cloud App, you can use the obscure [Cmd/Ctrl]+[Opt/Alt]+[ R ] to refresh your app. If you are a perpetual license holder, you can access the update via Help>Updates…

    Refer to this for any installation issues: Keeping Lightroom Up-to-Date