• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Library module keywords

Joined
Apr 4, 2019
Messages
22
Location
Wiltshire, UK
Lightroom Experience
Power User
Lightroom Version
Lightroom Version
Lightroom Classic version: 10.4
Operating System
  1. macOS 11 Big Sur
After I merged two large catalogs to make a single one with over 520,000 previews in it, I have been seeing strange Keywording features.
1. Several thousand now show Madagascar in the 'Keywords and Containing Keywords' panel and also in the Will Export panel- only a few hundred should be showing this.
2. When I try to enter the keyword 'Madagascar' in the Enter Keywords panel, I get an internal error message popup saying:
?:0: attempt to index field 'parent' (a nil value)
3. I cannot delete Madagascar as the keyword doesn't appear in the Enter Keywords panel.
4. I have lost the predictive text function when entering keywords
5. The keyword Madagascar only appears once in the keyword list, and in the correct place in the tree, under Africa.
6. There is no mark (-) against madagascar in those previews that are not taken in madagascar, yet they show madagascar in the containing keywords view.

Any suggestions as to how to fix this?
 
Joined
Apr 3, 2012
Messages
1,023
Lightroom Experience
Advanced
Lightroom Version
Classic
when I used Terminal and the script as described by John it returned with "Error: Unable to open database.
You likely provided the path to the catalog folder rather than .lrcat file. But no need to sweat if you're sending the catalog to Philippe.
 
Joined
Jun 20, 2009
Messages
18,206
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Would you please send me your email address in order that I can send you my .lrcat.
Peter

You do not need Philippe’s email. Click on the “Link” option. Up load the file and the website will generate a link to that file.

You can then either send Philippe that link in a Forum PM or poste it in a reply here for everyone. ;)


Sent from my iPad using Tapatalk
 
Top