Issue With Topaz Mask AI

kitjv

Active Member
Joined
May 3, 2012
Messages
263
Location
Oregon, U.S.A.
Lightroom Experience
Intermediate
Lightroom Version
Lightroom Version
9.3
Operating System
macOS 10.15 Catalina
I recently downloaded a 30-day trial of Mask AI. Although I was quite pleased with its ability to mask & replace the background, whenever I saved the composite image as a TIFF file, it could not be opened in Lightroom, Photoshop, or Mac's Preview. I have a support ticket filed with Topaz Labs regarding this issue. But, according to Topaz Labs, it does not seem to be a general issue. I am curious if those of you who use Mask AI are having a similar issue. And if so, have you come up with a workaround to open the composite image back into Lightroom? Thank you so much.
 

Jimmsp

Senior Member
Joined
Jan 9, 2011
Messages
1,030
Location
Green Valley, Arizona, USA
Lightroom Experience
Advanced
Lightroom Version
Classic
I use Mask AI with no issues. But apparently I have two differences from you. First, I have a pc with Windows 10 Pro as my OS, and second I have only used Mask AI as a plug-in to Photoshop. I send a tiff file from LR Classic to PS, and operate on a layer with Mask AI. I generally "save" the file back to the hard drive, and LR opens it right up. I can also "save as" with no issues. In both cases PS is producing the tiff, not Topaz.
 

kitjv

Active Member
Joined
May 3, 2012
Messages
263
Location
Oregon, U.S.A.
Lightroom Experience
Intermediate
Lightroom Version
Jim, thank you for the suggestion. Although I only use PS occasionally, I will try opening Mask AI as a PS plugin rather than a standalone app. Again, thank you.
 
Top