Impromptu Slideshow

Siobhán Bermingham

New Member
Joined
Mar 18, 2016
Messages
3
Lightroom Experience
Intermediate
Lightroom Version
Hi there, I have LR 6.5 operating on Windows 10. When I run the impromptu slideshow in the Library Module none of the navigation keys work, e.g. if I press the right arrow to move on one image it will do it once but not do it again. The back arrow to move back also doesn't work and neither does the Escape key to exit the slideshow. It just slowly and solemnly goes through the entire selection of photos until I right click my mouse to escape. I want to use the impromptu slideshow as a way of quickly managing my newly uploaded photos - X to flag photos for deletion or P to flag them as picks etc. - it's nice to be able to view them large at full resolution. The X and P options only seem to work occasionally. I recently viewed an impromptu slideshow of 360 images only to find that it had only flagged about 15 photos:(. However, I CAN run impromptu slideshow successfully when I'm in the Slideshow module and it seems to behave itself there. So it appears that it DOES work, but not in the way expected.
 
Joined
Nov 27, 2013
Messages
1,441
Location
Queensland
Lightroom Experience
Intermediate
Lightroom Version
Classic
I think you could do this flagging by just using 'Full Screen' view from the library grid or collection view.
Have your slideshow images in a collection.
Turn on "AutoAdvance" Menu>Photo>AutoAdvance
Press 'F'

However-
I tried the Impromptu Slideshow with the auto-advance turned on, and for me it does do exactly what you are trying to do - and fast! Both left/right cursor keys work and Esc exits.
It works best if you have slide changes set to 'Manual', the Slideshow Mode as 'automatic' may be upsetting your slide advance.
 

Siobhán Bermingham

New Member
Joined
Mar 18, 2016
Messages
3
Lightroom Experience
Intermediate
Lightroom Version
I switched on the Auto Advance and changed the slide show to Manual and it has helped a bit. Escape still doesn't work and it still doesn't mark all Flagged images. But the right and left arrows work well. I'm wondering at this stage if it has something to do with the fact that I'm viewing my images from an external hard drive? Maybe there's a time lag?
 
Joined
Nov 27, 2013
Messages
1,441
Location
Queensland
Lightroom Experience
Intermediate
Lightroom Version
Classic
I do not have technical knowledge that may help, but I think you are "Using a pile-driver to hit in a tack".
If you want to flag images as you say - "managing my newly uploaded photos" then the Grid view- full screen [F] is the faster and more reliable way to work. Lightroom will not have to 'build' the slideshow.
LR v6.4 had a bug that Impromptu Slideshow would not work at all until the slideshow had been played (or created) in the Slideshow module. Maybe there is still remnants of this bug that is slowing you now.
 

Siobhán Bermingham

New Member
Joined
Mar 18, 2016
Messages
3
Lightroom Experience
Intermediate
Lightroom Version
Thanks for your reply. I only started to use this method of reviewing and selecting (using impromptu slideshow) after it was recommended. I love the fact that you get a clean screen and full resolution images. But what you suggested (Grid and F) is exactly what I want anyway and works without the problems I encountered using Impromptu slideshow. Maybe there is a bit of the bug remaining and hopefully will be fixed in the next update. Thanks for your solution to my problem. I can now get on with what I want to do :)
 
Top