• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The November 2019 Lightroom updates are now available. Lightroom Classic includes the ability to export the same photos as multiple sizes/formats in a single export, content aware fill for panorama edges and more. It does require a catalog format upgrade and there are updated system requirements, so you may want to wait a few days before upgrading.
    Lightroom (cloud-based service) has export options (such as TIFF format, renaming and color space), custom sort order on the desktop, copy/paste to multiple photos on iOS and more.
    The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.
  • Are you using the cloud-based Lightroom apps for Windows, Mac, iOS, Android, Apple TV and Web? Then you'll love my new book, Adobe Lightroom - Edit Like a Pro!

    You'll learn how to use the Lightroom cloud ecosystem to organize, edit and share your photos. You'll also come to understand the thought processes used by professional photographers when they're editing their own photos, so you can transform your photos quickly and easily. And better still, the eBooks are updated for every release, so it's always up to date.

Importing from multiple iOS devices

Joined
Jul 17, 2019
Messages
36
Lightroom Version
Cloud
Operating System
iOS
My iPhone automatically happily imports its camera roll into LrCloud.

I also installed Lr on my iPad and my wife's iPhone, so that photos taken on those devices would be automatically imported into my 'master' library.

But it's not working. I've checked all the settings on both additional devices, but they simply don't upload pictures taken on those devices.

Is this a known bug (or feature?) or am I doing something wrong? Does anyone else have this problem?
 
Joined
Sep 29, 2007
Messages
21,763
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Hi Carlos. Have you tried shooting a new photo on your iPad or wife's iPhone? The Auto Import only imports new photos created after it's enabled, and they do need to open LR once in a while to let it start uploading, as it's not a complete background task.
 
Joined
Jul 17, 2019
Messages
36
Thanks Victoria

Yes, just double checked and took a photo using my iPad camera (stock camera app).

Lr on the iPad happily synced to the cloud copy of my photos, but has ignored the photo I just took on the iPad.

These are the setting I think are relevant on my iPad (connectivity of which is fine - I am typing on it)
 

Attachments

Joined
Sep 29, 2007
Messages
21,763
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
If you go to the blue button at the bottom of the Organize view and try to add them manually, do they add ok? And sync back to the desktop?
 
Joined
Jul 17, 2019
Messages
36
If you go to the blue button at the bottom of the Organize view and try to add them manually, do they add ok? And sync back to the desktop?
Partial success. When I:
a) manually add photos, then they sync OK. Lr did ask me for permission to access the camera roll (I said yes of course) and I thought that had fixed it
b) when I take photos with the Lr app, then they sync to master library too (desktop/web)

but... even after this, if I take photos with the regular iPad camera app, they don't appear in the Lr library on the iPad to begin with

:-s
 
Joined
Jul 17, 2019
Messages
36
update. Same problem with iPad is also on my wife's iPhone. I can take photos with the Lr app and also manually add photos to the Lr local library. Both these successfully sync back to other devices

The problem is getting my iPad and my wife's iPad to automatically import photos taken on their local stock iOS camera apps.

This works fine on *my* iPhone.

Does anyone else have auto camera roll import working across multiple iOS devices?
 
Joined
Feb 1, 2010
Messages
11,731
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Does anyone else have auto camera roll import working across multiple iOS devices?
I have my iPhone enabled for auto import, which works whenever I use the native phone camera (though usually I prefer the Lr camera). So I just tried to enable the same auto add on my iPad, and I ran into the same problem as you describe, i.e. I can manually import from the Camera Roll, but LrMobile would not auto add new pictures taken with the native camera.

So then I tried enabling auto add on an Android phone, and that did work without any issue. However, I then found that the auto add on the iPad would now work correctly (for new captures, those taken before it started working did not auto add). I can't explain that, but it does feel like a bug of some description, so I'd suggest reporting it to Adobe using the bug report link at the top on the page.
 
Joined
Jul 17, 2019
Messages
36
So then I tried enabling auto add on an Android phone, and that did work without any issue. However, I then found that the auto add on the iPad would now work correctly
Wow. That's got the hallmark of being a bug alright. Sadly I don't have an Android device I can use to trigger the iPad syncing.

Thanks for testing and sharing. I will file as a bug.
 
Joined
Jul 11, 2008
Messages
68
iPad photos taken on the Apple camera are being imported automatically into Lightroom on my wife‘s iPad.

What are your iPad settings in Settings > Lightroom? On our phones there is an option to “allow Lightroom to access Camera”. The iPad strangely doesn’t have an option to allow the the Camera, but does have an option to allow “Lightroom to access Photos”

Will send some screenshots later if useful.
 
Joined
Jul 17, 2019
Messages
36
@mikebore thanks for this. Two things:

1. re your wife's iPad working, do either of you also have an iPhone connected to the same Lr account? And if so, is that working OK too? That's the scenario I'm trying to achieve

2. Thanks for sharing your Settings screens. Mine are identical

I'm running the latest of everything (iOS 12.4 on iPad and iPhone) plus Lr is up to date on mac and these devices
 
Joined
Feb 1, 2010
Messages
11,731
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Have you tried disabling the auto-add on the iPhone, then trying the iPad again. And if that works, try re-enabling the iPhone again? Just trying to find a way to kick-start it all.
 
Joined
Jul 17, 2019
Messages
36
Have you tried disabling the auto-add on the iPhone, then trying the iPad again. And if that works, try re-enabling the iPhone again? Just trying to find a way to kick-start it all.
Thanks @Jim Wilde It's a good idea and I suspect that might work, but I am nervous that my iPhone might not re-connect again - and that's my primary capture device
 
Joined
Jul 11, 2008
Messages
68
@mikebore thanks for this. Two things:

1. re your wife's iPad working, do either of you also have an iPhone connected to the same Lr account? And if so, is that working OK too? That's the scenario I'm trying to achieve

2. Thanks for sharing your Settings screens. Mine are identical

I'm running the latest of everything (iOS 12.4 on iPad and iPhone) plus Lr is up to date on mac and these devices
1. Yes we also have two iPhones which connect to the same Lr account without problem.

2. That is a puzzle then! I am out of suggestions.

A slight correction/addition to what I wrote earlier...but not relevant to your problem.
I realised of course that the "Allow Lightroom to use camera" setting is about taking pictures with the Lightroom camera. Since my wife's iPad did not apparently have an option to allow Lr to use the camera, I tried taking a picture with the Lightroom camera, expecting it not to work. What happened is that it immediately popped up a request to allow Lr to use camera. Having given this the camera option does now appear in the Lr settings screen. See screenshot.

Screenshot 2019-08-20 at 11.51.07.png
 
Joined
Sep 29, 2007
Messages
21,763
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Have you tried disabling the auto-add on the iPhone, then trying the iPad again. And if that works, try re-enabling the iPhone again? Just trying to find a way to kick-start it all.
That was my next suggestion too. I have it enabled on at least 2 devices.
 
Joined
Jul 17, 2019
Messages
36
Well... suddenly and inexplicably, everything has started working. What I actually did was:

1. reboot the iPad. Then that started working :)
2. *But* the iPhone stopped :confused:
3. So I rebooted the iPhone and that started working again :D
4. And without doing anything my wife's iPhone started working :oops:

I'm not touching anything ever again
 
Top