• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.

Importing from iPhone stopped working

Russell Banks

Member
Joined
Nov 17, 2016
Messages
26
Lightroom Experience
Advanced
Lightroom Version
A few weeks ago (prior to upgrading to Mac OS Sierra), Lightroom lost the ability to import from my iPhone 6. The import menu sees the phone and displays the images, but when you click the Import button the thumbnails go away and it says "Importing photos" on the gray screen, but the progress bar fails to advance. This happens even when I try to import just one photo.

On top of that, there’s no way to get out of the stuck import process. I have to force quit Lightroom.

Image capture has no problems moving the files from the iPhone to the Mac.

Any ideas what the problem might be? It worked fine for years...


Best,
Russell
 
Joined
Jun 20, 2009
Messages
18,219
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Welcome to the forum. I'm not having any difficulty. I have an iPhone6 and connect via USB.

Have you disabled the Photos app and have you set "Connecting this camera opens:" to point to "Adobe Lightroom" in the Image Capture app?
 

Russell Banks

Member
Joined
Nov 17, 2016
Messages
26
Lightroom Experience
Advanced
Lightroom Version
Thanks for the quick response!
How do I disable the Photos app? I’m not familiar with disabling an app on a Mac, other than deleting it.
I set "Connecting this camera opens:" to point to "Adobe Lightroom" in the Image Capture app, but it made no difference. Besides, I often connect my phone to the Mac for syncing music, apps, etc., and don’t want Lightroom starting up every time I do that. Make sense?

One new thing I learned: When it gets stuck importing, if I disconnect the phone, it gets unstuck and I don’t have to force quit Lightroom. I’ve attached screenshots of when it’s stuck, and the message I get when I unplug the phone while it’s stuck.
Screen Shot 2016-11-18 at 08.10.52.png
Screen Shot 2016-11-18 at 08.09.04.png
 
Joined
Jun 20, 2009
Messages
18,219
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Last edited:

Russell Banks

Member
Joined
Nov 17, 2016
Messages
26
Lightroom Experience
Advanced
Lightroom Version
Unfortunately, Photos was not in my startup list. Since I don’t use it, there’d be no point in having it start up every time I logged in. And Photos is not auto-launching. I’d turned that off ages ago.

I tried using my iPad, and got the same result. Switched USB/Lightning cables, tried a different USB socket in the back of the computer, even unplugged all other USB devices.

I also connected a Ricoh WG-4 camera via its USB cable, and it worked fine. So it’s apparently something to do with iOS.

Thanks for your suggestions.


Regards,
Russell
 
Joined
Jun 20, 2009
Messages
18,219
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
So it’s apparently something to do with iOS.
Are you running iOS10.1.1? I have an iPhone6 too and as I said, not a problem. Are there videos on the iPhone? I seem to recall some problems with video files and LR.
 

Russell Banks

Member
Joined
Nov 17, 2016
Messages
26
Lightroom Experience
Advanced
Lightroom Version
Yes, 10.1.1. No videos.

I figure it must be the phone, since LR on my Mac imports my Canon 70D files through its SD card slot and imports from the Ricoh's via its USB cable just fine. I’m heading out for a few days, then I’ll concentrate on issues with the phone, rather than Lightroom. Thanks!
 

Russell Banks

Member
Joined
Nov 17, 2016
Messages
26
Lightroom Experience
Advanced
Lightroom Version
I’m not sure I’ve found the problem, but the imports seem to be working now. There was a thumbnail for a jpg on the iPhone that, in the Lightroom import menu, didn’t have an import checkbox. I deleted it on the phone, and the import started working again. Perhaps the very presence of this file on the phone was jamming up the import queue. We’ll see if the imports continue working over the next few weeks. Thanks for your help!
 
Top