• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! There's new Presets in all versions, Super Resolution on the desktop, new Sharing options and more. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Import function freezing up

Joined
Jan 10, 2021
Messages
12
Lightroom Version
Lightroom Classic, current Version
Operating System
  1. macOS 10.14 Mojave
LRCC has suddenly stopped importing (otherwise, LRCC is working--I can edit, etc). I have rebooted several times, and the import function stops at different points, but here is what is basically happening: the images are on a QXD card. I know the card reader is working, because when I go to Finder and click on Nikon 850, the images show up there. And sometimes they will show up in LR. But I have not been able to get the import function to let me use the right hand side. I can't change any of the settings there, and instead, the dreaded Circle of Death begins spiralling and will not quit (I waited for over an hour once). When that starts, everything freezes--I cannot even activate the Quit Lightroom function. I just have to force quit the computer and hope it reboots. It has not. I have been using LR since LR2, and this has never happened before. I can't find anything on Google that addresses this. Please help. Dexter
 
Joined
Nov 5, 2017
Messages
1,186
Location
UK
Lightroom Experience
Power User
Lightroom Version
Classic
Can you be clear on the actual version please? current doesn't confirm it (and it's no use to anyone looking in the future too).

Btw LRCC doesn't exist, it's a term dropped a long time back, it's Lightroom Classic or Lightroom Desktop (cloud-based). And yes, I know it's still the CC App for loading them!

A screenshot may help us - especially with the comments you make about the right-hand side.

Also, try copying the files to the local disk first - issues like this are almost always a problem with the reader or the cable.
 
Top