• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Image rendering not sharp when switching to Develop module.


Aug 23, 2017
Lightroom Experience
Lightroom Version
Lightroom Version
Operating System
  1. macOS 13 Ventura
Hi all

I use Lightroom Classic on my MacBook (M1) and have found that the image in the Develop module is not sharp in comparison to when it’s viewed in the Library module. It’s as if the Develop module image hasn’t rendered properly.

I believe this issue is a common one (?) and is solved by turning off LR’s use of the GPU.

This works and both images render correctly, but then when I move the sliders to make any adjustments in the Develop module, the image blurs slightly as the slider is moved and then sharpens up again when I stop the adjustment. Basically you can’t see the adjustments happen ‘live’.

Turning the use of the GPU back on fixes this issue but we’re then back to square one with the Develop module image not being sharp.
Is there a fix for this issue or is it a case of ‘live with it’ or buy a new laptop with a better GPU!

I don’t have these issues in Capture One, for what it’s worth. Perhaps C1 uses the GPU differently.

Thanks lots
Hello and sorry for all the updates. Had a free-ish day here so went deep on the testing!

The display is an external one. An Eizo ColorEdge CG223W. The laptop is closed. I guess the display is pretty old now... if that's relevant!

Screenshot attached


  • Screenshot 2023-11-09 at 18.00.44.png
    Screenshot 2023-11-09 at 18.00.44.png
    94.2 KB · Views: 20
Another thing to try: Set System Settings > Displays > Color Profile to "sRGB IEC61966-2.1". Does the problem still occur?

LR sometimes has issues with specific third-party color profiles. though the issues are typically around colors or refusing to display an image at all. But it's a quick test. I think by default the Eizo ColorNavigator produces ICC v4 profiles, which in the past LR wasn't always happy about.
No change after trying that. The colour profile was produced on a SpyderXPro
I tested the issue on this configuration and wasn't able to reproduce the problem:

- Macbook Pro (M1 Pro, 14", 2021, 16 GB)
- Mac OS 13.5.1
- LR 13.0.1,
- Eizo CG2700X running at "1600 x 900 (low resolution)" in Mac OS System Settings > Displays.

So somewhat different than your configuration: different version of the M1 chip, different version of Mac OS (with different graphics drivers), different display.

I tried large sample raws from these cameras, including the sample you provided:


I'm not able to update the laptop to Mac OS 14, which could potentially have different graphics drivers.

The thing that remains suspicious is that, even after forcing it to re-evaluate, LR thinks your computer doesn't support full acceleration, saying:

"Init State: GPU for Image Processing supported by default"

The M1 definitely supports full acceleration.

Possible next steps:

- Do you have Preferences > General > Use Smart Previews Instead Of Originals For Image Editing checked? That can sometimes cause issues.

- If you have access to another external display (e.g. a friend's), try that. Perhaps there's a bad interaction between the particular display, the GPU, and LR.

- Calling Adobe support about this is likely to be an exercise in frustration -- it's unlikely they'll have any more insight. With more complicated issues, they're hit or miss (more miss than hit). But if you're desperate...

- You could also post a bug report in the Adobe forums:

That is very unlikely to lead to an immediate resolution, though it would be a place for others to add their "me toos" if it happens to them. Adobe won't pay any attention to it unless there is a recipe for easily reproducing it (which we don't have) or unless many others start reporting the same symptoms. As I mentioned before, if this were a general issue with some M1 laptops, we'd have seen a large number of reports on the forums by now.
Hi and thanks for taking the time to try and reproduce this issue. It was never going to be simple, unfortunately.

Yes, my plan is to try a different monitor, and a different laptop (M2) with my monitor & LR.

Will report back.
Did you see my last suggestion?

- Do you have Preferences > General > Use Smart Previews Instead Of Originals For Image Editing checked? That can sometimes cause issues.
Did you see my last suggestion?

- Do you have Preferences > General > Use Smart Previews Instead Of Originals For Image Editing checked? That can sometimes cause issues.

Sorry. Yes. I tried this some time ago as one of the first potential solutions that came to mind.

I’ll let you know how the monitor test goes.

Today’s shoot was edited in Capture One!

I tested this issue with my laptop (and obvs my LR setup etc) on my friend's monitor. We were't able to reproduce the issue. LR still felt that the system only supported 'limited' acceleration, but there was no problem with any blurry image when switching between the two modules.
Very strange and unusual to see a bug dependent on the particulars of the display.

In the Adobe forums, someone recently reported very similar symptoms with an external display that went away after rolling back to LR 12 and then rolling forward to LR 13 again. Not at all clear it's the same underlying problem.
FYI. I tested this issue today with my friend's laptop (M2 Max) and my monitor and it reproduced itself exactly the same. So basically it's an issue between LRC and the monitor.

FWIW, LRC had set his GPU to full acceleration automatically.
Any update on this issue? I'm having the same problem with blurry images in my LR. I have a MacBook Air Ventura 13.3 M2. I've talked to both Adobe and Apple support for hours and no one has been helpful. Starting to regret upgrading my laptop, lol.
Jesika, please provide details about your issue:

1. Are you using an external display when the issue occurs?
2. Is the blurriness on the external display or the laptop display?
3. In which module, Library or Develop?
4. Does the blurriness resolve when you click to zoom to 100% and then back to Fit zoom?
5. Please do the LR menu command Help > System Info and copy/paste the entire contents here so we can see exactly which versions of hardware and software LR thinks you're running and important LR options that are set.
- I have a MacBook Air M2 Ventura 13.3 built in Retina 13.6-inch (2560 × 1664. It's happening on my laptop not an external display.
- Lightroom classic 13.0.2
- At first images were blurry in develop and fine in library, after talking to adobe customer service for two hours yesterday, now library and develop are both blurry.
- Blurriness is not fixed with zooming. Also tried turning gpu off and on, neither helped.
- Tried changing the file handling in catalog settings to see if a different preview size and quality would work better, but nothing.
- I'm working strictly with smart previews and do not have the raw files on my computer.
- Just upgraded my laptop, and never had these issues with my MacBook Air Monterey.
Your symptoms are different than SiW's, which were specific to one external display and weren't tied to smart previews. Some more troubleshooting steps:

1. I suspect that when using smart previews, LR doesn't access the regular preview cache for Loupe view in Library or Develop -- the smart previews are themselves the previews. But you could try deleting the preview cache, as described here:

2. Clear the Camera Raw cache by going to Preferences > Performance > Camera Raw Cache Settings > Purge Cache.

3. Try making a new catalog and importing a few dozen smart previews. Does the problem occur with that new catalog?

4. Try resetting LR's preferences:

LR sometimes soils its preferences file, and resetting it can fix all sorts of wonky behavior. That article explains how to restore the old preferences if resetting doesn't help.

5. Do a clean uninstall/reinstall of all Creative Cloud apps:

These last two options are hail-mary plays, but they do sometimes clear up difficult issues with a surprising range of symptoms.