• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The November 2019 Lightroom updates are now available. Lightroom Classic includes the ability to export the same photos as multiple sizes/formats in a single export, content aware fill for panorama edges and more. It does require a catalog format upgrade and there are updated system requirements, so you may want to wait a few days before upgrading.
    Lightroom (cloud-based service) has export options (such as TIFF format, renaming and color space), custom sort order on the desktop, copy/paste to multiple photos on iOS and more.
    The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.

How to Upgrade from LR 4.4?

meliwilli

New Member
Joined
Dec 2, 2019
Messages
3
Lightroom Version
4.4
Operating System
macOS 10.14 Mojave
I havent upgraded since 4.4 . Adobe told me I had to first upgrade to LR6, then I could get LR Classic. But LR6 isn’t available anywhere! ! I am really wondering if I should even attempt any upgrade at all because it’s all so confusing. I have a brand new Apple Mac and things are working pretty well on it but I have to be careful not to upgrade to Catalina or my entire LR 4.4 ( maybe it’s 4.7)won’t be working at all I have been told. this whole thing is making me want to get some other program. Any suggestions . I am not tech savvy and this whole thing is weird. Why did they do CLOUD? I have talked to many photographers, half HAtE cloud based LR, the other say its great.
 
Joined
Nov 5, 2017
Messages
421
Location
UK
Lightroom Experience
Power User
Lightroom Version
Classic
Hi and welcome!

Adobe advised you incorrectly. If you install Lightroom Classic (that's the local folder-based one, not the cloud one) then your Lightroom 4 catalog will upgrade to the new 9.0 catalog. And it's absurd that Adobe tell you to upgrade to 6, it simply isn't available.
 

meliwilli

New Member
Joined
Dec 2, 2019
Messages
3
Hi and welcome!

Adobe advised you incorrectly. If you install Lightroom Classic (that's the local folder-based one, not the cloud one) then your Lightroom 4 catalog will upgrade to the new 9.0 catalog. And it's absurd that Adobe tell you to upgrade to 6, it simply isn't available.
It is absurd and I was totally confused by their answer. Also, I think I read on Laura SHoe that my collections wouldn’t transfer over . I don’t want to lose those. Is this right?
 
Joined
Jun 20, 2009
Messages
14,935
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
It is absurd and I was totally confused by their answer. Also, I think I read on Laura SHoe that my collections wouldn’t transfer over . I don’t want to lose those. Is this right?
I don't think that Laura would make such a statement about Lightroom Classic. It might be true for Lightroom (cloudy).
Converting an LR4 catalog file to a Lightroom Classic v9 catalog file will convert everything in the v4 catalog to the v9 structure. That includes collections.
 

rewagner

OSXerSince10.1
Joined
Dec 2, 2019
Messages
4
Location
Washington, DC metro area
Lightroom Experience
Advanced
Lightroom Version
6.x
Not sure about LR 4 but LR 6 “perpetual” works fine with Catalina (if you do an in place upgrade or user migration from a previous version of macOS). The only 64-bit incompatibility is with the installer executable.


Sent from my iPhone using Tapatalk
 
Joined
Jul 2, 2015
Messages
9,166
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
I believe that the confusion comes from the fact that migrating a Lightroom 4 catalog to the cloud version is not possible. For that you need at least a Lightroom 6 catalog. Adobe support is notorious for their poor knowledge of their own products. These are young people who get a couple of manuals and are then let loose onto the poor public.
 

meliwilli

New Member
Joined
Dec 2, 2019
Messages
3
I believe that the confusion comes from the fact that migrating a Lightroom 4 catalog to the cloud version is not possible. For that you need at least a Lightroom 6 catalog. Adobe support is notorious for their poor knowledge of their own products. These are young people who get a couple of manuals and are then let loose onto the poor public.
Thank you, my confusion is dissipating . And friend told me the same thing, but it's good to know from elsewhere . I will come here for help!
 
Top