• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.

help needed moving LR to a new iMac

jure

New Member
Joined
Aug 31, 2021
Messages
3
Lightroom Version
6.14
Operating System
  1. macOS 11 Big Sur
I ran into a problem moving LR to a new iMac and would welcome any suggestions.
I just joined LRQ have been using the guide for moving to a new computer (thanks - it is a great guide).

Environments
Old - everything LR related works (w slow performance)
  • iMac 21.5 2017, 8 GB
  • MacOS - Catalina 10.15.7
  • LR version 6.14
New
  • iMac 27" 2020; 32 GB/SSD drive
  • MacOS - Big Sur 11.5.2
Steps to set up the new iMac:
  • Copied all files to the new iMac via Time Machine / Migration Assistant
  • This included photos, LR catalog, LR application, Creative Cloud, plugins, etc.
The first time I started Lightroom on the new computer I logged in to Creative Cloud first, then LR launched and everything worked perfectly - we only had one "missing photo". Everything was great! But all subsequent attempts to launch LR on the new computer have failed.

There may be an issue with how LR access is managed via Creative Cloud.
  • When I tried to log in to Creative Cloud from the old iMac when the new computer was logged in - I got error messages from Creative Cloud.
  • I logged out of Creative Cloud on the new iMac and was able to run LR on the old computer fine.
  • So we tried shutting down LR and logging out of Creative Cloud from the old iMac before trying again on the new Mac - but this didn't work. - I tried all different ways: dock icon, LR app in Applications, double clicking on the catalog file, and launching from Creative Cloud.

One other potentially relevant detail - "About LR" shows we have 6.14 Creative Cloud says that we have LR Classic. (Is this typical?)
Also - the goal is to upgrade to the Adobe Creative Cloud Photography plan and install the real LR Classic app. But we wanted to get there in steps - get a new iMac, get existing LR working, upgrade to LrC. Should we just jump to that step? If so, do we need to uninstall 6.14 first? Can 6.14 and LrC exist together?

Thanks for any insights anyone can provide.
 
Joined
Jul 2, 2015
Messages
11,502
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Logging into the Creative Cloud changes Lightroom 6 from a perpetual licensed version to the subscription version Lightroom CC2015, which is the predecessor of Lightroom Classic. As you were planning to upgrade to Lightroom Classic anyway, do so right now. There is no reason to try to get an ancient version to run on the latest MacOS if you do not plan to keep using it anyway (which is a wise decision. Lightroom 6 is obsolete).
 

jure

New Member
Joined
Aug 31, 2021
Messages
3
Thanks Johan. That explains whyLR Classic shows up in the CC Desktop app, even though we never actually upgraded and moved to LrC.
I will move forward with the LR Classic subscription purchase.

Do you have any suggestion on if we should uninstall the LR we have (6.14 - via Lightroom CC2015) before installing the new LR Classic or if we should keep it as is and use the upgrade option from CC desktop?
 

jure

New Member
Joined
Aug 31, 2021
Messages
3
Thanks Johan. That explains whyLR Classic shows up in the CC Desktop app, even though we never actually upgraded and moved to LrC.
I will move forward with the LR Classic subscription purchase.

Do you have any suggestion on if we should uninstall the LR we have (6.14 - via Lightroom CC2015) before installing the new LR Classic or if we should keep it as is and use the upgrade option from CC desktop?

Update: Purchased the Photography plan and installed LR Classic - 10.4. It upgraded the catalog. All is good.
The old Lightroom still won't run - but isn't needed. It is a puzzle why it launched once and won't start again - but no more help is needed.
 
Top