• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Library module HEIC photos disappear (missing)

Joined
Dec 31, 2019
Messages
19
Lightroom Version
Lightroom Classic version: 10.3 [ 202105281559-8dc50eb4 ]
Operating System
  1. macOS 11 Big Sur
Although I am primarily a Nikon shooter, I often use my iPhone XR (iOS 14.6) when on-the-go. In several instances over the past month, however, Lightroom has lost the imported HEIC photos. Roughly speaking:
  1. use LR to import directly from iPhone connected by USB,
  2. mark some photos to be rejected,
  3. delete (from disk) all rejected photos,
  4. add keywords and captions to remaining photos,
  5. mark some photos as Flagged,
  6. develop Flagged photos (crops and minor exposure adjustments),
  7. create a new collection under SmugMug publisher (v3.2.2.0),
  8. publish to SmugMug,
  9. quit Lightroom.
Worked fine, each time. However, days or weeks later I open Lightroom and discover that some photos are Missing. The LR catalog knows they exist, but they are definitely not there on disk. I import photos into folder/subfolder/filename structure using the Capture date, e.g.,
/Users/dfk/Personal/Photos/Lightroom/2021/2021-05-16/2021-05-16-89099.HEIC
It appears that the Missing photos are those posted to SmugMug... so perhaps it is the SmugMug plugin that caused the data loss?

To make matters worse, I cannot recover the HEIC photos because they are not in Trash, never made it to any backup disk, and have been fully deleted from the iPhone; I use Image Capture to delete photos from iPhone after import to LR, and it actually deletes photos (does not move them to Recently Deleted).

So I downloaded the jpgs from SmugMug and dropped them into the folder. In LR I clicked the "!" to let me find the missing photo, and selected the jpg. After overriding LR's warning that the filename was different, LR was happy: the missing photos were found. All looked good. I quit LR and restarted it. The photos were marked again as Missing... and the jpg files were gone!! LR appears to have deleted them. Bizarre.

Anyone else seen this kind of problem? I'm not sure whether it is a bug in the LR-iPhone import process, in the LR library management system, or in the SmugMug publisher, or some combination of them.

dave
 
Joined
Feb 1, 2010
Messages
13,179
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Joined
Dec 31, 2019
Messages
19
I've never heard of the "ViewFinders" program, but yes, that thread describes my problem nearly perfectly. It seems plausible that the data loss was caused by the Smugmug Plugin; I'll investigate that thread for options.
 
Top