• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Having Import problems

jjlad

Active Member
Joined
Jan 18, 2009
Messages
458
Location
Winnipeg, Canada
Lightroom Experience
Intermediate
Lightroom Version
Cloud Service
Lightroom Version
10.2
Operating System
  1. Windows 10
Hi there,
I must be doing something incorrectly with respect to importing. I got a new phone, a Samsung S21Ultra, which takes fairly decent photos so I'm using it as my walkaround/backpackaround etc. camera now instead of lugging an SLR.
At first I was creating the necessary folder in Windows, eg. 20210305 and then I'd plug in the phone via USB and drag and drop photos using the Windows "My Phone Companion" app because I only had a few photos at a time. Then I'd import them into LR 'at their current location'. That My Phone Companion only allows dragging one at a time. You can't select more.
I wanted to try importing directly to LR.
I catalog by Year/Month/Day:
1619986414879.png


I select Import (which now takes forever to open despite being on a new HP Omen laptop with 64g Ram and a Core™ i7-10750H (2.6 GHz) and a NVIDIA® GeForce RTX™ 2070 (8 GB GDDR6 dedicated) graphics card.
The Import dialog opens slower now than it ever did and gets slower with each new Lightroom Update.
While waiting I get a "not responding" popup:
1619986485335.png

I ignore that and eventually the Import Dialog opens.
My phone is plugged in and shows up in the Source selection area in the Import dialog, where I have "New Photos" selected and "Don't import suspected duplicates"
1619986722968.png


80% or more of the images on the phone have already been imported into in my LR catalog, but with the above selections, EVERY PHOTO ON THE PHONE is checked.
In the Destination panel I try to navigate to the dates I want to import but am finding the whole interface now just crazy since it is showing all the photos being available to dump into any of the locations I have on my drive. If I select the specific month eg. 202012 the top part of the list looks like this:
1619986910330.png


As shown ...it makes it looks like every photo is "NEW" ...like LR's Import Module is not recognizing photos already in the catalog.
Does anyone know what I'm doing wrong or have a workaround for this, or should I consult Adobe directly?
Thanks in advance.
 
Top