Google Photos plugin obtained from Adobe is not working at all

jjlad

Active Member
Joined
Jan 18, 2009
Messages
471
Location
Winnipeg, Canada
Lightroom Experience
Advanced
Lightroom Version
Classic
Lightroom Version
10.2
Operating System
  1. Windows 10
Hi there,
I have a bunch of photos I decided to archive on Google Photos. Google' own Upload option keeps crashing on Chrome, Chrome Incognito and even on Edge. I contacted their support so they are aware of their issue.
I looked for another way and found this program being offered on Adobe Exchange so paid the $18.85 Canadian.
A page opened with a link to Creative Cloud and in that there was an installation button. I clicked on that and the program appeared to install itself and confirmed that the installation was successful.
I restarted Lightroom and the option to Export to Google Drive doesn't appear anywhere, there is no option in my Plugin Manager to add or activate it and there is nothing in Publish Services about it.
So, I have absolutely no idea where it got installed or how to activate it. With the deadline to upload photos on one's free Google Photos space approaching a midnight tomorrow, I'd like to get the task done but with this happening I can't. I've emailed the address that comes up in Creative Cloud, but am not holding my breath on a US long weekend and Adobe support is not available at all on the weekend either.
Would anyone happen to have a suggestion on this??
Thanks in advance.
 
Joined
Apr 3, 2012
Messages
1,031
Lightroom Experience
Advanced
Lightroom Version
Classic
Adobe never integrated its Exchange with LR Classic, and it can be very confusing trying to install something you've purchased. In this case, the Where To Find It tab on the Exchange page for the plugin explains how to install it:

In general, I recommend not downloading plugins via the Exchange. Instead, go directly to the plugin developer's web site, where you can usually download the plugin much easier.
 

jjlad

Active Member
Joined
Jan 18, 2009
Messages
471
Location
Winnipeg, Canada
Lightroom Experience
Advanced
Lightroom Version
Classic
Thanks for the advice John. Wow ...that's a pretty bad lash on Adobe's own store.
I think I'll just request a refund since it doesn't work, can't be found in LR even though Creative Cloud confirms it is installed, and support for it seems very thin.
I've stumbled onto a workaround. I open Google Photos, Create a new album and simply drag the photos into it from File Explorer in Windows. The support staff at Google One support just said they'd get back to me and were so uninformed about their own program they didn't even know about that. I just stumbled onto it trying things. Incredible. I have about 50% of what I want to upload done now and will have no problem getting the rest done that way before their deadline.
 

jjlad

Active Member
Joined
Jan 18, 2009
Messages
471
Location
Winnipeg, Canada
Lightroom Experience
Advanced
Lightroom Version
Classic
Thanks for the advice John. Wow ...that's a pretty bad lash on Adobe's own store.
I think I'll just request a refund since it doesn't work, can't be found in LR even though Creative Cloud confirms it is installed, and support for it seems very thin.
I've stumbled onto a workaround. I open Google Photos, Create a new album and simply drag the photos into it from File Explorer in Windows. The support staff at Google One support just said they'd get back to me and were so uninformed about their own program they didn't even know about that. I just stumbled onto it trying things. Incredible. I have about 50% of what I want to upload done now and will have no problem getting the rest done that way before their deadline.
Further to this I followed your link to the Where to find it and then followed the process and got it installed. It is working but painfully slowly. Not near as fast as the drag and drop method I adopted on my own. I'll try it on raw files and tiffs since it will export as a jpg without having to create one separately.
 
Top