FONTS - specifically Lithos Pro added to LR2/Mogrify

BH1

New Member
Joined
Aug 20, 2009
Messages
15
#1
Is it feasible to add this font to LR2/Mogrify? I have been using this font with elements and would really like to somehow get it into my LR flow.

Thanks,
Brian
 

Victoria Bampton

Lightroom Queen
Staff member
Administrator
Moderator
Lightroom Guru
Joined
Sep 29, 2007
Messages
20,515
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
CC Cloud
#2
Hi Brian, welcome to the forum!

Mogrify can be a little bit fussy about some fonts, but I've just checked the Mac version, and it works on here, so it's worth a go. It's just a case of navigating to the font using the LR/Mogrify export dialog, like the screenshot below. On May the path is /Library/Fonts/LithosPro-Regular.otf but on Windows it'll be something like C:WindowsFonts... it might be a hidden folder, so if you can't find it, don't panic.
 

Victoria Bampton

Lightroom Queen
Staff member
Administrator
Moderator
Lightroom Guru
Joined
Sep 29, 2007
Messages
20,515
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
CC Cloud
#4
I really shouldn't reply before I've had my first cup of coffee.... took the screenshot, saved it nicely on the desktop.... and left it there. Doh!
 

BH1

New Member
Joined
Aug 20, 2009
Messages
15
#5
I am unable to "choose" with windows LR2?Mogrify. It only gives me the option to refresh list but Lithos Pro is not an option on the font list. :(
 

Victoria Bampton

Lightroom Queen
Staff member
Administrator
Moderator
Lightroom Guru
Joined
Sep 29, 2007
Messages
20,515
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
CC Cloud
#6
Ah ok, so the Windows version works differently. Are any other fonts missing? Is it a normal ttf file? Does it appear in all other programs?
 

Brad Snyder

Senior Member
Joined
Nov 20, 2007
Messages
6,293
Location
Port Deposit, Maryland USA
Lightroom Experience
Intermediate
#7
I'd like the answer to this one as well, I'm not seeing *any* fonts in that box, my only choice is refresh, which seems to do nothing.
Edit: although, I just realized, I haven't tried restart/reboot yet, since noticing the problem while investigating this thread.
 

BH1

New Member
Joined
Aug 20, 2009
Messages
15
#8
I haven't checked other at this point but I will compare the fonts. Definitely differences but it is an Adobe font that I am aware of and it is in PSE7. It must reside somewhere.
 

BH1

New Member
Joined
Aug 20, 2009
Messages
15
#10
Seems that there are only a couple that want to work on my maschine. Is there an easy way to convert the font? I can't say that I have ever tried this before. In fact I have searched and to no avail been able to find the hiding spot that PSE uses to hide the font. :(
 

B.K.

New Member
Joined
Nov 20, 2007
Messages
15
Location
Warsaw, Poland
#11
As far as I remember I used a trial version of FontCreator... On the other hand I'm not so sure if the licence for OpenType Font wasn't broken in this manner :)

Likely, the LithosPro resides in drive:\Program Files\Common Files\Adobe\Fonts
 

Victoria Bampton

Lightroom Queen
Staff member
Administrator
Moderator
Lightroom Guru
Joined
Sep 29, 2007
Messages
20,515
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
CC Cloud
#12
Ah hah! That might be it! I wonder if Mogrify only looks in the standard fonts folder...? You never know, copying it to normal fonts *might* work.
 

B.K.

New Member
Joined
Nov 20, 2007
Messages
15
Location
Warsaw, Poland
#13
I copied this to Fonts folder, but I think LR2/Mogrify can't see *.otf.
I remember that I also tried to add the font to the Mogrify configuration file... Maybe it was the solution instead of conversion to ttf. I'll look at it when at home and let you know.
 

B.K.

New Member
Joined
Nov 20, 2007
Messages
15
Location
Warsaw, Poland
#14
Ok I've checked it.

I've added this entry:
<type name="LithosPro" fullname="Lithos Pro Regular" family="Lithos Pro" foundry="" weight="4''" style="normal" stretch="normal" format="otf" metrics="" glyphs="c:\windows\fonts\LithosPro-Regular.otf"/>
to the type-ghostscript.xml file in the imagemagick folder

And I've got no lithos*.ttf font in the Fonts folder.
 

BH1

New Member
Joined
Aug 20, 2009
Messages
15
#16
B.K. - YOU ROCK!!!!! :) They need little jumping and flipping smilies!!!!

So I have finally been able to produce the Lithos Pro Regular thanks to B.K.

The string entry was added via copy and paste to the type-ghostscript.xml file. The LPR file was pasted to imagemagick and tada!!!! Here is the proof.
 

Victoria Bampton

Lightroom Queen
Staff member
Administrator
Moderator
Lightroom Guru
Joined
Sep 29, 2007
Messages
20,515
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
CC Cloud
#18
Well done! That's an impressive bit of troubleshooting!
 
Top