• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! Color Grading and improved zoom across the whole Lightroom family, plus graphical watermarks for the cloud-based Lightroom apps, as well as the usual new cameras, lens profiles and bug fixes. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

'Filter failed' and Epson P700

Joined
May 6, 2017
Messages
40
Lightroom Experience
Advanced
Lightroom Version
Classic
Lightroom Version
9.3
Operating System
macOS 10.15 Catalina
I've spent a few hours trying to troubleshoot this issue. I have a new Epson SureColor P700 printer, but can't get it to print from Lightroom. Part of the difficulty in troubleshooting this is all the variables: Is it the new printer itself? The Epson printer driver? The wireless connection? The latest version of Lr? The Mac OS?

Trying to isolate the problem, I spent an hour on the phone with Epson, who concluded it's a Mac problem, and then another hour with Apple, who concluded it's a Lightroom problem. I won't go through all the troubleshooting steps we took, but I did uninstall and reinstall the Epson driver three times, and checked virtually every setting on the Mac side. After lots of experimentation, the Apple rep decided the problem lies with the Printer Settings that are available in the Print dialog box that you get when you hit Print in Lightroom.

I'm able to print to the P700 from other applications, and also by selecting the Bonjour version of the printer instead of the TCPIP version, but then I get no Printer Settings choices—so that's not an acceptable workaround. According to Apple tech support, the Printer Settings in the dialog box are the 'filter' referred to in the attached error message that 'fails.'

SO, I'm at a loss for how to solve this. I've also tried many different settings for the ICC profile in Lightroom, and for Media Type, and Print Quality in the Print dialog box, but always get the 'Filter failed' message and the file doesn't print.

I guess maybe I'm paying the price for getting a brand-new printer and putting myself on the bleeding edge of technology. Any suggestions would be appreciated.
 

Attachments

Joined
May 6, 2017
Messages
40
Lightroom Experience
Advanced
Lightroom Version
Classic
I should also mention that I've "reset the Mac printing system" several times by deleting the printer and all associated files and adding it back in. Didn't fix the problem.
 
Joined
Sep 29, 2007
Messages
22,670
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
I'd start by hooking it up by USB to exclude the wireless connection. I'd also try reinstalling the driver while connected by USB, because I have vague recollections of having issues getting the right driver with a previous Epson printer. It's a long shot, but you've done all the sensible stuff!
 
Joined
May 6, 2017
Messages
40
Lightroom Experience
Advanced
Lightroom Version
Classic
Thank you, Victoria. I'll try that, but I don't have a cable with USB connections at either end lying around (or an adapter). Plenty of cables, just not that one.

I did discover another possibly useful clue: I always get the Filter Failed message when I select the TCPIP version of the printer in the dialog box, but I can print when I select the AirPrint version of the printer. (See attached screenshots.) But the downside of using the AirPrint version is that I don't get all the Printer Settings options that appear in the dialog box for the TCPIP version.
 

Attachments

Joined
May 6, 2017
Messages
40
Lightroom Experience
Advanced
Lightroom Version
Classic
Well, after reading many other related posts and trying various ways to isolate the problem, it's fixed. I do not think it was a Lightroom problem; I think it was an Epson printer driver/Mac OS issue. As a troubleshooting step, I installed the Epson driver software on my laptop (the problem I was trying to solve was printing from my iMac) … and it worked perfectly right away. So I went back to the iMac and deleted the Epson driver and all associated files and folders yet again (fourth time). I re-downloaded and re-installed the Epson printer software, and it worked.

I wish I had a clear explanation for why it worked, so that I could share it and help other people who have the same problem, but I don't. I imagine, though, that other people WILL have the same problem as this brand-new Epson printer gets into more Mac users' hands.

Thanks for the advice. I appreciate it.
 
Joined
Sep 29, 2007
Messages
22,670
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
That's great to hear Nicky, thanks for the update!
 
Top