• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! New cameras (including the Canon R5/R6), lens profiles and bug fixes, and the ability to disable built-in lens corrections for specific new cameras. Here's the usual list

Files not writable

Joined
Jul 3, 2019
Messages
11
Lightroom Version
9.2
Operating System
macOS 10.15 Catalina
Have uploaded files from five memory cards used in two cameras without a problem. However, when attempting to export some files to other folders in LR - apparently restricted to two of the memory cards - receive a message: "EXPORT RESULTS - Some export operations were not performed - TRIANGLE make writable (1) - File no". Similarly, when attempting to rename these files, a message comes up: "PROBLEM WITH RENAMING FILES - Some photos will not be renamed because they are missing or not writable".

I am using LR 9.2 and MacOS Catalina 10.15.3

Any thoughts, please?
 
Joined
Nov 5, 2017
Messages
830
Location
UK
Lightroom Experience
Power User
Lightroom Version
Classic
Joined
Jul 3, 2019
Messages
11
Thank you. I have looked at Security and Privacy as shown in the link you sent to me. Network Volumes was not ticked and so I have ticked it, but it has not made any obvious difference - I am still getting the same messages when attempting to export or rename. Is there anything else I might try?
 
Joined
Sep 29, 2007
Messages
22,660
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Where are the files stored, and where are you exporting them to?
 
Joined
Jul 3, 2019
Messages
11
The files are in subfolders within a folder in Lightroom Images. Each subfolder contains images uploaded from one memory card. It seems that files in three of the subfolders can be exported but those in the remaining two can not. The destinations are all subfolders within other folders in Lightroom Images. Very frustrating!
 
Joined
Jun 20, 2009
Messages
16,488
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Have tried but clicking Get Info doesn't't produce anything at all.
If you have a file, folder or volume selected, right clicking on the selected file, folder or volume will produce a context menu. Clicking on the menu item "Get Info" will always produce a "Get Info" dialog about that item. At the bottom of that dialog will be a "Sharing and Permissions" section
 
Joined
Sep 29, 2007
Messages
22,660
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
The files are in subfolders within a folder in Lightroom Images.
I was thinking more along the lines of internal drive, external drive, NAS, etc. That said, if some of the folders work and others don't, folder permissions would make the most sense.
 
Joined
Jul 3, 2019
Messages
11
Right-clicking on a selected sub-folder produces a menu starting with "Create Folder Inside...." and finishing with "Get Info". Clicking on Get Info does nothing. Right-clicking on a selected individual file produces a menu starting with "Open in Loupe View" and finishing with "View Options" - no reference in the list to Info.
 
Joined
Sep 29, 2007
Messages
22,660
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Ah! In Finder, not in Lightroom.
 
Joined
Jul 3, 2019
Messages
11
Thank you. Have now looked at Sharing Permissions in Finder. All five folders have the "you can read and write" description.

Out of curiosity - and the need to use the files - I have re-imported a few images to newly-created folders. Some are from a no problem memory card and some from one containing images that I have not been able to export. I have then attempted to export the files to a new-created destination folder. The results are the same as they were originally - some export and some don't. Hope this may help.
 
Joined
Nov 5, 2017
Messages
830
Location
UK
Lightroom Experience
Power User
Lightroom Version
Classic
Sounds like you found the issue then. Change the permissions on one, try it, I believe it'll be fine. It'd be interesting to know where in the chain it happened (so the permissions on the original SD card, does that mean there's an SD card corruption? I'd low level format it anyway!)
 
Joined
Jul 3, 2019
Messages
11
Have changed the permissions on a few and it works. The Get Info drop-down in Finder showed a ticked LOCKED in the General section. I have un-ticked that to change the permission to read and write - is that best or only way to do it?

Will treat the SD cards with suspicion!
 
Joined
May 12, 2011
Messages
3,310
Location
Canada
Lightroom Experience
Advanced
Lightroom Version
David,
Good work. Some cameras allow you to lock images on the SD card. I suspect that will carry over to the files after they've been copied to your hard drive.
 
Top