• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The August 2019 Lightroom updates are now available. Lightroom Classic includes advanced GPU support, batch HDR/pano merge and more. Lightroom (cloud-based service) has deleted photos on the desktop/mobile apps, as well as video support and batch metadata editing on Android. The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Export Filenumber Name Prefix Not working

JamesStewart

New Member
Joined
Oct 10, 2017
Messages
2
Lightroom Experience
Advanced
Lightroom Version
Operating System:
MAC os Sierra
Lightroom Version:
CC 2015.12

Question or Description of Problem:

The problem is when I try to export a batch and rename them with the "File naming -> Rename To -> Custom Settings" option and add "Filenumber Name Prefix" to the name, it simply doesnt show anything. Blank space. If I write "TM_'FileNumberNamePrefix_20", it exports as "TM__20".
It worked perfectly before when working on just the raws, but with my new workflow I open the pictures in Photoshop "Edit In -> Photoshop -> Edit as Copy", I click "Save" and it saves as a Tif and opens a copy in my Lightroom Catalogue that I then try to export in the same way, it doesn't work. The files are called "IMG_number-Edit.tif".

Could I fix this problem just by adjusting my workflow from lightroom to Photoshop? I just want to make short fixes on the Lightroom images in photoshop and export them BACK to Lightroom
 
Joined
Jul 2, 2015
Messages
8,818
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Classic 7
You say 'File number prefix, but I suppose you mean suffix. I think the 'Edit' suffix is what is causing the problem. File number suffix assumes that the file name is a few letters, followed by four or five numbers. The file number suffix is those numbers. However, in your case the file ends with '-Edit', so there is no file number suffix.
 

JamesStewart

New Member
Joined
Oct 10, 2017
Messages
2
Lightroom Experience
Advanced
Lightroom Version
Ah, alright! So how would you suggest I fix this? :) In an automated way
 
Joined
Jul 2, 2015
Messages
8,818
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Classic 7
The easiest way to fix this is by not adding '-Edit' to the file name of an image that is sent to an external editor. That is the default, but there is no reason to do this. When you edit a raw file, Photoshop can save a tiff or psd with the same name, because the file extension is different. You can change this in the preferences - external editor.
 
Top