• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

"Export containing keywords" doesn't work if synonym is used

Joined
Sep 28, 2008
Messages
624
Location
Tacoma, WA
Lightroom Experience
Intermediate
Lightroom Version
Classic
Lightroom Version
10.1.1
Operating System
  1. macOS 10.15 Catalina
If I assign a keyword synonym to an image, containing keywords are not exported, even if "Export containing keywords" is checked. If I assign the keyword itself (non-synonym), containing keywords ARE exported if that box is checked.

This isn't a huge deal, but it does make synonyms less useful.
 
Joined
Sep 29, 2007
Messages
22,872
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Joined
Apr 3, 2012
Messages
744
Lightroom Experience
Advanced
Lightroom Version
Classic
If I assign a keyword synonym to an image
How are you assigning a synonym to the image? In the Keyword Tags panel, if you enter a synonym, LR will create a new keyword of that name and assign it rather than assign the synonym's keyword to the photo. In general, the only thing you can do with synonyms is use them to search for photos, despite ten years of feature requests:
 
Joined
May 9, 2015
Messages
802
Location
Palo Alto, CA
Lightroom Experience
Power User
Lightroom Version
Classic
I can't replicate this problem on Windows/10, LrC 10.0. To test it, I created a KW structure with a Parent KW (including a synonym). Under this parent are two child KW's, one with a synonym and one without a synonym. All 3 of these KW's have the top 3 check boxes checked (Include on export, Export containing, and Export Synonym). I assigned both child level keywords to an image and exported. The resulting JPG image had all the expected information . It had both the keyword and synonym from the parent, the keyword name from both child keywords and the synonym from the one child keyword that had it.

Keyword struc
1613932243228.png


Keywording Panel
1613932264253.png


Export settings
1613932633373.png


Keywords on exported image
1613932691719.png
 
Top