• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Are you using the cloud-based Lightroom apps for iOS, Android, Windows, Mac, and Web? Then you'll love my book, Adobe Lightroom - Edit on the Go!

    You'll learn how to use the Lightroom cloud ecosystem to organize, edit and share your photos. You'll also come to understand the thought processes used by professional photographers when they're editing their own photos, so you can transform your photos quickly and easily. And better still, the eBooks are updated for every release, so it's always up to date.
  • 21 February 2024 It's Lightroom update time again! See What’s New in Lightroom Classic 13.2, Mobile & Desktop (February 2024)? for all the update news. It's mainly new cameras, new lenses and loads of bug fixes in this release.

Error when trying to migrate Apple Photos library into Lightroom CC

Not open for further replies.


New Member
Mar 26, 2016
Lightroom Experience
Lightroom Version
Cloud Service
Lightroom Version Number
Lightroom CC 2.1.1
Operating System
  1. macOS 10.14 Mojave
I am trying to use the migration tool to migrate my apple photos library. But after I start, it sits at 1% progress for a while, then I get an error window saying "Could not access apple photos library".

I have read this help page (Resolve issues while migrating Apple Photos to Lightroom CC) and checked each point:
- My photos are stored locally (not on an external drive)
- I use iCloud Photos, my library is setup as the "Use as System Photo Library"
- I have it set to Download Originals and the status of the sync is complete (ie not uploads or downloads happening)
- I have just repaired the library using the repair tool, and waited for everything to subsequently upload to the cloud again
- My copy of Lightroom is legit!

So the only thing left is this issue they describe where:
  • Apple Photos Library is locked and inaccessible. This can happen when the Apple Photos database is locked by a viewer application of services working on Photos Library for updating the data.
But I don't really understand how to check that? I have selected the apple photos library package in the Pictures folder and done a Show Info, and the Locked checkbox is unchecked. So I don't think that is the issue. Is there something else that might be causing it to be locked/inaccessible?

Or any other ideas of what I can check to get this to work?

Daft question, but tried a reboot? Sometimes that works wonders.
Daft question, but tried a reboot? Sometimes that works wonders.
Not daft - I always remind my Mum to do this ;)

I did try restarting with a few different sequences - restart and go straight to Lightroom and try vs restart, open photos and allow to update to iCloud, then try, etc. But no luck.

I found this video (https://www.youtube.com/watch?v=kMMI9k_XdPQ) where he describes (at about 5:50) having the same issue and a series of restarts fixed it. So will give it another go. But it sounds like it was random.
I think I've already seen you post on the bug forum, but if I'm imagining it, then I think it's one Adobe needs to investigate.
Yes someone else suggested to post there. So we will see what they say. Thanks
Think I just solved this. It is in fact a permissions issue.

I went to System Preferences > Security & Privacy > Privacy
Then I selected the Photos app in the left column
I could see the Adobe Lightroom CC app listed there, but the box allowing access was unchecked - check this box

Then I went back to Lightroom and tried the migration again. This time I got a system pop up asking if Lightroom CC could have access to the Photos app. I said Yes, then it ran.

So it seems that for some reason this system pop up didn't work the first time around, meaning I had to follow the steps above to manually allow access.
Oh well done Benzy! Thanks for the update.
Not open for further replies.