• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

"Copy and Import" function not working

Talia

New Member
Joined
Dec 27, 2016
Messages
18
Lightroom Experience
Advanced
Lightroom Version
Lightroom Version
7.3.1
Operating System
macOS 10.13 High Sierra
Hi,

After upgrading to the latest version of LR Classic (7.3.1), I am having a lot of difficulties "copying and importing" files.

When I select this function, the images copy onto my hard drive (I can see them there in the appropriate folder in the Finder), but they do not import into LR. In other words, the images are not visible in my LR catalogue.

I have found a work around. I close LR and then re-open it and repeat the copy and import function and everything behaves as it should. I need to repeat this (quit/relaunch) for every new folder of images that I wish to import. It is very time consuming!

Does anyone have suggestions how to resolve this LR problem? (I have already uninstalled and reinstalled LR, but the situation remains the same.)

Thank you
 
Joined
Sep 29, 2007
Messages
22,625
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
That does sound frustrating. So when it's not working, what can you see in the Import dialog? Or how would you expect them to import into LR?
 

Talia

New Member
Joined
Dec 27, 2016
Messages
18
Lightroom Experience
Advanced
Lightroom Version
I see nothing in the import dialog box. It remains empty and the task bar in the top left corner does not advance. It just stays in that positon (no matter how long I wait) until I cancel the function.

If things were working, I would expect to see thumb nails in the import dialog box of each image as it is imported. And this would be followed by building previews.

The other piece I neglected to mention is that the problem is intermittent. Yesterday, I spent hours trying to import via my work around (quitting and relaunching LR). This morning I tried again to import and for the last half hour everything is working as it should do. This has happened before...things works smoothly for awhile and then all of a sudden, copying and importing no longer works and I have to revert to the work around.

Any suggestions?
 
Joined
Sep 29, 2007
Messages
22,625
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Eugh, intermittent things are always harder to track down. Next time it happens, it might be interesting to see if you can select the card in the Files section below (like a hard drive) and whether that works when the device section at the top doesn't.
 

Talia

New Member
Joined
Dec 27, 2016
Messages
18
Lightroom Experience
Advanced
Lightroom Version
Thanks for this tip. I have been waiting for the problem to re-occur so that I can try this out. Unfortunately, importing in this manner doesn't seem to resolve the situation. Sigh!
 
Top