• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.

Converting Plug-ins from 5.7 to 6.0

Status
Not open for further replies.

VSCC Library

New Member
Joined
Nov 1, 2017
Messages
3
Lightroom Experience
Beginner
Lightroom Version
Operating System:Windows 10
Exact Lightroom Version (Help menu > System Info): 6.0 [1014445]

To get more copies of LR, we have upgraded our existing copies from 5.7 to 6.0. A year or so ago, someone was kind enough to write us some plug-ins to allow us to use custom metadata tags. These no longer work. Is there a simple fix for plug-ins written for 5.7 to make them work in 6.0? I would rather not ask for more favours from the author of the plug-ins if I can avoid it.I have searched the web with no luck.

Paul Spencer
VSCC Library
 
Joined
Oct 8, 2007
Messages
5,905
Location
London
Lightroom Experience
Power User
The thing is, Phil, you've got something to trade! The author of the plugin might need to drop your name to get media access to a VSCC event! I'm actually up in the Lakes for the one next week.

Anyway, plugins should work exactly the same as before. Is the plugin installed? Any error message?
 

PhilBurton

Lightroom enthusiast (but still learning)
Premium Classic Member
Joined
Nov 16, 2015
Messages
2,636
Location
California, USA
Lightroom Experience
Intermediate
Lightroom Version
Classic
Operating System:Windows 10
Exact Lightroom Version (Help menu > System Info): 6.0 [1014445]

To get more copies of LR, we have upgraded our existing copies from 5.7 to 6.0. A year or so ago, someone was kind enough to write us some plug-ins to allow us to use custom metadata tags. These no longer work. Is there a simple fix for plug-ins written for 5.7 to make them work in 6.0? I would rather not ask for more favours from the author of the plug-ins if I can avoid it.I have searched the web with no luck.

Paul Spencer
VSCC Library
To Plug-In authors,

Did the API get more restrictive between 5.7 and 6.0? Or did the plug-in author "hard code" a dependency on 5.7.

I thought that the API has never supported custom metadata. No?

Phil
 

VSCC Library

New Member
Joined
Nov 1, 2017
Messages
3
Lightroom Experience
Beginner
Lightroom Version
The thing is, Phil, you've got something to trade! The author of the plugin might need to drop your name to get media access to a VSCC event! I'm actually up in the Lakes for the one next week.

Anyway, plugins should work exactly the same as before. Is the plugin installed? Any error message?

Thanks John, I'll email you. If you can use your help to us to get media access, that is great!

Paul
 
Joined
Oct 8, 2007
Messages
5,905
Location
London
Lightroom Experience
Power User
To Plug-In authors,
Did the API get more restrictive between 5.7 and 6.0? Or did the plug-in author "hard code" a dependency on 5.7.
I thought that the API has never supported custom metadata. No?
Phil

No, Phil, there was very little change (sadly), so the plugin that I began should work fine.

Custom metadata fields are supported, but are a bit limited and can't be written to xmp. I don't generally recommend using them, unless you understand their limits and can (mostly) support them yourself.

John
 

VSCC Library

New Member
Joined
Nov 1, 2017
Messages
3
Lightroom Experience
Beginner
Lightroom Version
It looks like it was finger trouble. When I tried again to look at the error message, it installed OK.

Paul
 
Status
Not open for further replies.
Top