• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • 17 August 2022 It's Lightroom update time again and there's a couple of minor improvements as well as new cameras, lenses and bug fixes! See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

Color labels disappeared

mnfriedman1

New Member
Joined
Jun 16, 2022
Messages
2
Location
Hartsdale, NY
Lightroom Experience
Power User
Lightroom Version
Classic
Lightroom Version
Classic
Operating System
  1. macOS 12 Monterey
I used Migration Assistant to migrate all my files from my old iMac to my new Mac Studio. In Lightroom Classic I imported my old LR6 catalog and while I have all my photos and star ratings, the color labels have disappeared. Instead, for those photos that had color labels, in the grid view there is a white square in the lower right of the frame. This is the “Show photos with custom label” label. I’m hoping that none of the photos without the white square had color labels.

All files were either .dng or had .xmp sidecar files. What did I do wrong and is there a way to get the color labels back? I have over ten thousand photos and I do not even want to think about having to go through all of them to reestablish the color labels.

Thanks.
 
Joined
Jul 2, 2015
Messages
12,349
Location
Netherlands
Lightroom Experience
Power User
You probably used custom color labels, so you have to define these custom labels again.
 
Joined
Oct 8, 2007
Messages
6,092
Location
London
Lightroom Experience
Power User
What about the Color Label Set? ie the Metadata menu lets you say which colour is displayed for the text found in the Label field.

So find a photo that should have a colour. Go to the Metadata panel, switch it to Default view, and see what's in the Label field.

1655406544501.png
 

mnfriedman1

New Member
Joined
Jun 16, 2022
Messages
2
Location
Hartsdale, NY
Lightroom Experience
Power User
Lightroom Version
Classic
Thank you Johan and JohnBeardy, I think you are right. When I go to Metadata/Label I can see the custom text I have assigned to the different colors. But the colors themselves have switched back to the default.
Thanks very much for your help.
 
Joined
Oct 8, 2007
Messages
6,092
Location
London
Lightroom Experience
Power User
So you need to go to the menu Metadata > Color Label Set and change the active set, or possibly add one. The active set "maps" or takes the text in the metadata panel to the colours that are displayed.
 
Top