• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! Color Grading and improved zoom across the whole Lightroom family, plus graphical watermarks for the cloud-based Lightroom apps, as well as the usual new cameras, lens profiles and bug fixes. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes.

CMD + Delete shortcut not working - Problem Solved

Joined
Aug 6, 2015
Messages
39
Location
Lenexa, KS
Lightroom Experience
Advanced
Lightroom Version
Lightroom Version
8.3.1
Operating System
macOS 10.14 Mojave
My workflow involves rejecting any photos I don't want in a folder, then I go back and hit "CMD + Delete", get a question about whether I want to just remove the photos from LR or delete them from the disk, I choose delete. Over the past 2-3 weeks the CMD + Delete shortcut had quit working in Lightroom - and only in Lightroom. This was driving me crazy, I use the shortcut all the time. I tried lots of different things to try to isolate and solve the problem:
  • I could still go to "Photo-Delete Rejected Photo" in the LR menu system (which still lists CMD+Delete as the shortcut) and it worked fine.
  • Other shortcuts that used those keys worked fine so it didn't seem to be an issue with my keyboard, including using just the Delete key to delete a single photo.
  • I tried deleting a file in Finder, which uses the CMD+Delete shortcut to delete a single file. It worked.
  • I created a different keyboard shortcut (CMD+D) for LR using the Mac system preferences ->keyboard options; that shortcut worked. When I tried to add the delete key instead of a D in the shortcut in the Mac shortcut preferences I got the same "won't work" sound that I get when I try to use the shortcut in LR.
  • I have an expanded keyboard; If I pressed CMD+Delete+Delete (Backspace) the shortcut worked in Lightroom.
Solution:

I finally did a search that did not include the word "Lightroom" and discovered that other Mac users were experiencing the same problem in Finder. The solution was to add a different shortcut (as I did with CMD +D) and assign it to the menu item where it's not working, then go back and delete the newly created shortcut. Weird, but it also worked for me in Lightroom.
 
Joined
Sep 29, 2007
Messages
22,670
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Thanks for sharing nkawoods! I've seen something similar in the past where another app's service has commandeered a shortcut that Lightroom would usually use. If that's the case, you might be able to spot it in System Preferences > Keyboard > Shortcuts.
 
Top