• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • It's Lightroom update time again! Just the usual new cameras, lens profiles and bug fixes. See this blog post for Lightroom Classic and this blog post for the Lightroom Cloud Ecosystem changes. If you use a custom monitor profile on macOS, note that the Classic performance bug is not yet fixed.

catalina upgrade lost Epson profiles

reachfar

New Member
Joined
Jun 9, 2015
Messages
2
Lightroom Experience
Power User
Lightroom Version
9.3
Operating System
  1. macOS 10.15 Catalina
I upgraded to Catalina and the Epson P600 profiles no longer appear. I tried an Epson reinstall but that didn't help.
 
Joined
Nov 30, 2012
Messages
551
Lightroom Experience
Power User
Lightroom Version
Classic
There is a specific problem where printer profiles go missing in macOS 10.14 and later. If this is that problem…
You already tried the first thing, which is to reinstall the Epson printer driver (after making sure it is the version for macOS 10.15).

When that doesn’t fix it, the next thing to try is, before reinstalling, delete the Epson printer from the list in System Preferences > Printers & Scanners. (It is normally OK to reinstall without deleting first, but for some problems it helps to delete the old printer instance first.)

When that doesn't fix it, another thing to try is completely resetting the Mac printing system. But if you have more than one printer set up, or a lot of custom printer settings, a printing system reset will delete all of them.

When none of the above fix it, the brute force way to resolve this is to either manually drag a copy of the Epson profiles out of their secret hiding place into ~/Library/ColorSync, or create an alias in that folder that leads to where the profiles are.

If you are dealing with this specific problem, the symptoms are that the profiles are actually on your Mac — because they are listed in ColorSync Utility under /Library/Printers/EPSON/InkjetPrinter2/ICCProfiles/ — but Lightroom Classic and possibly Photoshop are not listing them. (If the profiles don’t even show up in ColorSync Utility then you have a different problem.)

If you need more details about any of this, they are in a blog post I wrote about this problem:
Printer profiles missing on macOS: A permanent solution
 
Top