• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.
  • 21 February 2024 It's Lightroom update time again! See What’s New in Lightroom Classic 13.2, Mobile & Desktop (February 2024)? for all the update news. It's mainly new cameras, new lenses and loads of bug fixes in this release.

Can’t sync LR Classic to cloud, no matter what

Status
Not open for further replies.

greg.edwardsweb

New Member
Joined
Feb 20, 2023
Messages
1
Lightroom Version Number
12.2
Operating System
  1. macOS 12 Monterey
Cross posted from Adobe Community Support

TL;DR - how do I jump start syncing from classic when it just sits there doing nothing and says 'synced'?

I've been tearing out what little have my hair I have all weekend with this issue.

I haven't been taking may photos lately and haven't fired up Classic in a while, but I noticed some of the photos I've recently added via Lightroom simply would not sync with Classic on my MBP. They just sat in the sync queue doing nothing... for hours. Something must be up.

I signed and back in. Nothing. Rebooted the Macbook. Nothing. I then discovered the rebuild sync data option. I have nearly 10k images in my catalogue and when I tried this option is just sat there saying syncing for hours and hours and the number didn't change (even left it going over night).

I found this guide on the web and tried every suggestion. Still nothing.
https://visualsbychin.com/lightroom-classic-stuck-sync-fix/?utm_source=pocket_saves

I thought it might be an issue with my wifi, so tried linking to my phone. Still nothing.

Then I found this that mentioned DNS settings.
https://www.lightroomqueen.com/community/threads/sync-to-lightroom-option-missing-from-lightroom-cla...

I had cloudflare DNS set up on my macbook, so disabled them and it started syning! Yay! Unfortunately I had already removed everything from my synced items folder, so it went a bit crazy trying to consolidate everything with the cloud

In hindsight, I really wish I have left it alone to consolidate itself. But I'm an idiot. So I thought it would be best to simply delete everything in the cloud and start again. I only really sync smart previews so I didn't think I had anything to lose. So I followed this guide and deleted all synced data to to start afresh.
https://community.adobe.com/t5/lightroom-classic-discussions/how-to-delete-all-synced-photos/td-p/11...

Except LR Classic then failed to see the cloud at all. It just sat there saying "Synced". It didn't even reflect my actual cloud storage usage in the sync panel - just showed 0 btyes used. LR cloud and mobile devices still however synced properly with each other. It was almost as if Classic and LR cloud were using separate catalogues. I even tried setting up Classic on my spare mac with a fresh catalogue and that wouldn't sync either. Somehow after hours of proding around it started going again - I have no idea how. It synced a small collection so I thought I'd let it sync everything over night, except it didn't. It hung with several hundred left to upload.

Pretty much the state it was in when i started this adventure!

So I thought I'd try again, but this time only upload one collection at a time. So I deleted the cloud library again (with some trepidation considering the faff I had to sync it before), enabled a small collection of just 4 images and once again, for the last few hours, Classic is just sitting there saying synced when it's not syncing at all. It's just popped up recognising the correct amount of cloud storage - so that's something, but it's still not recognising and syncing with the cloud side of lightroom.

Any suggestions welcome please. It's doing my head in! At this stage I seriously considering completely removing the adobe suite with the cleaner tool and starting again, or more drastic, wiping my mac and starting again!

UPDATES

Another thought. Lightroom cloud is behaving perfectly on my ipad and iphone, but the desktop version (NOT Classic) is very, very slow to synchronise with the cloud.
FWIW, I have run the Creative Cloud Cleaner tool and run the "Fix Host File" and "Adobe Content Synchronizer (CoreSync) (6.2.0)" tools to no avail. According to the documentation, both of these tools should fix server/sync issues.

Another experiment. I installed the previous version of classic on my spare macbook and tried syncing that instead, to see if was a version issue. Lightroom immediately recognised that another catalog was 'synced' to the cloud and asked me if I would like to sync this new catalog instead. So I clicked yes, and it still isn't syncing. So this means Adobe's servers are seeing that I have a catalogue linked to the cloud, but it just won't sync with it.
It's almost as if Classic and cloud libraries are completely separate and unlinked entities.
 
Status
Not open for further replies.
Back
Top