Can't install LR 6.5.1

arthurhynes

New Member
Joined
Jan 4, 2009
Messages
9
I bought a Sony RX10Mk 3 and bought LR 6 (I have been using LR 4) to import the ARW files. According to what I read, I needed LR 6.5.1, so I updated to that. It is supposed to run on my Mac OS 10.8. After the update, when I try to open it, the message is Adobe Lightroom can't be opened because of a problem. Contact your developer...may need to re-install...
What do I do?
 
Joined
Jul 2, 2015
Messages
10,573
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
Why didn't you update straight to 6.12? Or is your MacOS X version too old for that?
 
Joined
Feb 1, 2010
Messages
12,705
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
System requirements for Lightroom on MacOS:

Adobe_Photoshop_Lightroom_system_requirements.png

Note that OSX 10.8 will only support Lightroom up to 6.1, which would explain the problem being encountered when trying to start 6.5.1.
 

arthurhynes

New Member
Joined
Jan 4, 2009
Messages
9
OS 10.8 cannot handle LR 6.12. I don't want to upgrade the OS because then other programs become unusable. Am I right that I need LR 6.5.1 for the Sony RX10mk3? Is there a solution with OS 10.8?
 
Joined
Jul 2, 2015
Messages
10,573
Location
Netherlands
Lightroom Experience
Power User
Lightroom Version
OS 10.8 cannot handle LR 6.12. I don't want to upgrade the OS because then other programs become unusable. Am I right that I need LR 6.5.1 for the Sony RX10mk3? Is there a solution with OS 10.8?

The only solution might be to convert your raw files with Adobe DNG Converter. The DNG files should open in earlier versions of Lightroom.
 
Joined
Jun 20, 2009
Messages
17,069
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
Cloud Service
OS 10.8 cannot handle LR 6.12. I don't want to upgrade the OS because then other programs become unusable. Am I right that I need LR 6.5.1 for the Sony RX10mk3? Is there a solution with OS 10.8?
What other programs become unusable? Almost every major app has updated to be compatible with MacOS. Quite frankly, I can't imagine any other program more important to run than the LR version that supports my (your new) camera. LR6.5.1 was the first update to support your camera. At this point because of numerous bug fixes, the recommendation is to update to the latest LR6.12. The last LR version supported on your OS X 10.8 is LR6.1 and this will not help you.
You have as I see it two possible options:
  1. Update incompatible app to run in Sierra.
  2. Set up aDual boot to run two version of OS X & Mac OS 10.8 for your legacy apps and MacOS 10.12.5 for everything else.
 
Top