• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The November 2019 Lightroom updates are now available. Lightroom Classic includes the ability to export the same photos as multiple sizes/formats in a single export, content aware fill for panorama edges and more. It does require a catalog format upgrade and there are updated system requirements, so you may want to wait a few days before upgrading.
    Lightroom (cloud-based service) has export options (such as TIFF format, renaming and color space), custom sort order on the desktop, copy/paste to multiple photos on iOS and more.
    The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom Classic questions. All the information you need is in Adobe Lightroom Classic - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. And better still, the eBooks are updated for every release, so it's always up to date.

Library module Blank Entry Can't Delete

Joined
Sep 3, 2017
Messages
23
Lightroom Experience
Advanced
Lightroom Version
Lightroom Classic version: 7.3.1
Operating System
macOS 10.13 High Sierra
Screen Shot 2018-05-14 at 20.47.51.png

I have a picture as above left which has no metadata or a link to a file. It's just a blank within the catalogue. I have tried to delete or remove photo and it won't budge. When I try to delete or remove I get nothing, no messages. Any ideas?
 
Joined
Jun 20, 2009
Messages
14,926
Location
Houston, TX USA
Lightroom Experience
Power User
Lightroom Version
First, you will not be able to do much with these thumbnails in the Publish Services section. The only action permissible from the Publish Service is to remove the image from the publish Service. Right Click on the image that is blank and choose "Go to Folder in Library". From that point you should be able to identify the file associated with the image, it's locating in Finder and any other information relevant to the image thumbnail. If you are still having this difficulty, exit LR and restart the app and let us know if the blank thumbnail is still present
 
Joined
Sep 29, 2007
Messages
21,842
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Hi Steve, that error seems to be popping up with a few plug-ins, especially a Logitech one. Do you have many plug-ins installed?

The other possibility is some minor catalog corruption, but I'd need to take a look at the catalog, if it continues happening.
 
Joined
Sep 3, 2017
Messages
23
Lightroom Experience
Advanced
Victoria, I have several plugins but the one that causes the problem is J Friedl's Photosafe plug in. The problem is associated with this blank photo (does not exist in reality but sits in the catalogue and I can't get rid go it.
 
Joined
Sep 29, 2007
Messages
21,842
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
And if you temporarily disable the Photosafe plug-in, will it delete then?
 
Joined
Sep 29, 2007
Messages
21,842
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
You're welcome to send me the catalog Steve, and I'll see what I can do. Or you can ignore it! ;)
 
Joined
Sep 3, 2017
Messages
23
Lightroom Experience
Advanced
The catalogue is 1.8GB!! I will put a copy on by Creative Cloud and send you the link. Many thanks for this. It is appreciated as it is certainly annoying.
 

PhilBurton

Lightroom enthusiast (but still learning)
Premium Classic Member
Premium Cloud Member
Joined
Nov 16, 2015
Messages
1,863
Location
California, USA
Lightroom Experience
Intermediate
Lightroom Version
Classic
Victoria, I have several plugins but the one that causes the problem is J Friedl's Photosafe plug in. The problem is associated with this blank photo (does not exist in reality but sits in the catalogue and I can't get rid go it.
Jeff Friedl seems very responsive to bug reports. I suggest you head over to Jeffrey's Lightroom Goodies (Plugins and Tools) and find an email address so you can report this bug. Be sure to provide the EXACT file name, including the "revision" number.

Phil Burton
 
Joined
Sep 29, 2007
Messages
21,842
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Got it Steve. Which folder is that problem photo in?
 
Joined
Sep 29, 2007
Messages
21,842
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Scratch that, found it. Catalog's on it way back.
 

Seano

New Member
Joined
Mar 21, 2019
Messages
1
Lightroom Experience
Intermediate
Lightroom Version
Hi there! Thanks for raising this issue! Sadly, I seem to be having the same problem. When I go to the Library module > Catalog drop down > select All Photographs > then click on Delete Rejected Photos, I get 664 blank thumbnails that show up, but I am unable to delete them, remove them, or remove them from the catalog.

All of the photos show blank entries in the Metadata panel (screenshot attached). Also, if I right click on any of the photos, I am not given any options. No matter what I do, I can't get rid of them. Any suggestions? [I am using Lightroom Classic v8.2 and I'm on a Mac running Mojave 10.14.2.]
 

Attachments

Joined
Sep 29, 2007
Messages
21,842
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Yeah, that sounds like the same problem. Feel free to follow the instructions above to send it over and I'll take a look. (I'm out of the office till Monday.)
 

stratiformus

New Member
Joined
Oct 8, 2013
Messages
6
Lightroom Experience
Advanced
Hi,
I also have this problem.
1757 photos (out of 140,000 photos) that are grey, with no other data.
I cannot delete them. I cannot change them. All I was able to do was tag them with a keyword.

How do I get rid of them?
 
Joined
Sep 29, 2007
Messages
21,842
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
1757? Wow, that's the highest I've heard of. There isn't a way to get rid of that many right now, but Adobe is looking into the problem. I'd be happy to share your catalog with them to help them narrow down the cause and solution. Any idea where they came from?
 

stratiformus

New Member
Joined
Oct 8, 2013
Messages
6
Lightroom Experience
Advanced
Hi,
1757 is the count. I know this because they all have a keyword ("Trashme") and so are easy to identify. I just can't delete them.

I think that it may have occurred in conjunction with some import problems I am having with iPhone imports, basically:
  • I'd like to plug my iPhone in, import all photos, "Don't import suspected duplicates". This would allow me to keep a copy of everything in my phone, in my Lightroom catalog.
  • However when importing photos from the iPhone, there is a tendency for duplicates to appear. Not every photo gets duplicates. Not every photo gets imported. This appears to be a recent problem. I don't recall ever having it before. All the affected photos have metadata showing iPhone 8 Plus.
  • At some point I've imported photos, and identified some of them as duplicates. I've tagged them for deletion. (Keyword tagged, not flagged, so I can use multiple tags, in case I have to do it multiple times.....)
  • I don't know how they came to be blank. Later, when going through my keywords, I've found these to still exist, but they are 'blank'. It's NOT a link issue, its a catalog issue. I'm aware of the difference.
I can live with the grey "photos", but I'm worried that it will lead to catalog corruption later. Also, its an issue of 'housekeeping' that bothers me.

The issue of having trouble importing photos from my iPhone is far more troubling. I can't seem to do a clean import, without getting duplicates and import problems. This means I don't have many iPhone photos in my catalog, which is my... well... primary catalog, and 70% of the reason I even persist with Lightroom. Because of issues like this, and the need for a subscription, I'm closer and closer to dropping lightroom entirely. (Not a threat, just a statement of fact).

If you can help, let me know how.

Thanks
David

PS. Also getting 'help' from here:

 
Joined
Sep 29, 2007
Messages
21,842
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Great, that thread is exactly where I'd have sent you. I've updated the internal bug this morning with some extra info, and mentioned your case to Rikk. He's liaising with the engineers. I've only seen about 6 cases of these ghost images in more than a year, so I think they're fairly rare, but it still needs tracking down and fixing.

The duplication issue is odd, and would be worth reporting separately. I've seen a couple of reports recently of Lightroom on macOS not "seeing" all of the photos on a memory card when it's connected as a macOS Device (as opposed to browsing through the Files section of the dialog), and in those cases, macOS Image Capture wasn't seeing them either. It might be useful to know whether Image Capture "sees" all of the photos on the phone.
 

joefoetoe

New Member
Joined
May 9, 2019
Messages
2
Victoria, I too have the dreaded blank images - seven of them. I'm a little handy with sqlite and not afraid to experiment on a catalog if you can explain the process without too much trouble. And/or I'm happy to submit it to you for forensics, repair, whatever. it's about 4.8g zipped.
 
Joined
Sep 29, 2007
Messages
21,842
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Hi joefoetoe, welcome to the forum!

I've done a fair bit of exploration and there's not a database hack I'm happy with, but I am passing these catalogs onto an Adobe engineer so he can figure out the cause and fix. I'd love to pass your catalog on too. I'd only need the lrcat bit, not the previews, so that should bring the size right down.

 

joefoetoe

New Member
Joined
May 9, 2019
Messages
2
Victoria, the 4.8g .lrcat.zip was too large for wetransfer. Meanwhile, a discovery: for fun, i sorted catalog images on capture time. Wouldn't you know, the grayed images, dutifully took their positions in a series of photos I had toyed with in a dubious manner (regarding replacing duplicates or somesuch). Examinining the AgLibraryFile of .lrcat in sqlite, I can see the (presumably orphaned) image filenames. I've visited the corresponding thread in Rikk Flohr's thread that you linked, but I don't want to crosspost, so please forward this to him with my email address and I'll await an email from one of you to privately link my dropbox.
 
Joined
Sep 29, 2007
Messages
21,842
Location
Southampton, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
You're very welcome to post it on there, but as requested, I will pass your details to Rikk so he can drop you an email to get your catalog.
 
Top