Before and After "\" key

Colin Grant

Active Member
Joined
Apr 18, 2016
Messages
325
Location
Norfolk
Lightroom Experience
Intermediate
Lightroom Version
Classic
Lightroom Version
10.2
Operating System
  1. macOS 11.0 Big Sur
I have reset an image, so no adjustments are recorded, yet when I click on the \ in develop there is a difference between before and after. What am I missing? I would have expected them to be the same.
 
Joined
Feb 1, 2010
Messages
12,866
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
"Before" doesn't have to be the initial Import step in the develop history. It's possible to set any intermediary step as the "Before" point (by right-clicking on a particular intermediary step and using the option to "Copy History Step Settings to Before"). It's possible you may have previously done that. Easy to check, without using the "\" key to toggle before and after, use the history to switch between the initial Import step and the last "Reset Settings" step....they should be the same. If they are, then you can right-click on the Import step and use that option to reset Import back to "Before", after which the "\" toggle should not show any differences.

Try that, and let us know if that solves the mystery.
 

Colin Grant

Active Member
Joined
Apr 18, 2016
Messages
325
Location
Norfolk
Lightroom Experience
Intermediate
Lightroom Version
Classic
RIght, it is the original image and as suggested by Jim "imported image" is different to the "reset one". However right clicking on "original" only gives me the options shown in the screen shot. If I right click on the image there is an option to "make reference photo"
 

Attachments

  • Screenshot 2021-04-07 at 09.39.57.png
    Screenshot 2021-04-07 at 09.39.57.png
    428.5 KB · Views: 23
  • Screenshot 2021-04-07 at 09.44.45.png
    Screenshot 2021-04-07 at 09.44.45.png
    560.2 KB · Views: 25
Joined
May 9, 2015
Messages
811
Location
Palo Alto, CA
Lightroom Experience
Power User
Lightroom Version
Classic
Any chance the image had XMP data (either as a sidecar file or embedded in the image file) when it was imported? This could account for a discrepancy between thmported "imported" state which would include the XMP changes and the "reset" state which would not. Just a theory.
 

Colin Grant

Active Member
Joined
Apr 18, 2016
Messages
325
Location
Norfolk
Lightroom Experience
Intermediate
Lightroom Version
Classic
It really is a mystery as "before" is now an image with no adjustments and "import" is an image with some adjustments. I am obviousely missing something but somehow the imported image is picking up adjustments as it comes into Lr. Maybe it is something to do with the raw defaults - I have Lr set to camera settings (and it renders a poor image imo)?
 

Colin Grant

Active Member
Joined
Apr 18, 2016
Messages
325
Location
Norfolk
Lightroom Experience
Intermediate
Lightroom Version
Classic
This is not going away. Just edited a clean raw file. No previous edits whatsoever other than import. Checked import in history and as expected it showed no adjustments whatsoever. Edited image and then did a reset. Back in history, reset shows the image as it was when imported (that is with no edits) whilst import shows the image with a lot of adjustments. From what I read Classic seems to be accumulating lots of little bugs over the last releases and I wonder if this is another?
 
Top