Auto-Sync Lens Correction - Upright

Status
Not open for further replies.
Joined
Jan 18, 2009
Messages
536
Location
Winnipeg, Canada
Lightroom Experience
Advanced
Lightroom Version
Classic
Just wondering if I'm missing something. Shoot some real estate ...often in homes with tight halls, small lavatories etc., so use the upright tool frequently. When I select say 20 photos, turn on auto-sync and click the Upright Auto button, I see progress being made but when I get to each photo I have to 'reanalyze' to get it closer to correct. Is that to be expected or is there something I should be doing to get it right the first time?
 
Joined
Apr 26, 2014
Messages
80
Location
United Kingdom
Lightroom Experience
Intermediate
Lightroom Version
I suspect you're encountering a limitation of the Upright tool rather than an Auto Sync issue, but you can check that by applying the Auto Upright button to some images one at a time. If the Auto Upright results are different when used on individual images to when you use Auto Sync then you've found a bug.

If the results are unchanged you're just seeing the limitations of the tool. When you use Auto Upright LR has to analyse the image and try to determine which edges should be straight and warp the image accordingly. Depending on the image the results might be what you want, or more work may be needed. Images shot in small spaces (such as you are doing) potentially have more extreme distortions than, for example, a cityscape shot from a distance. The Auto Upright tool has to guess at what you're trying to achieve. The results are not always accurate, or might not be what you aesthetically prefer. The Auto button might get you closer to what you want than the starting point of the image, but more often than not you'll need to tweak the images afterwards to get a result that you're happy with.
 
Joined
Jan 18, 2009
Messages
536
Location
Winnipeg, Canada
Lightroom Experience
Advanced
Lightroom Version
Classic
Thanks Roger. It did seem to make an attempt but fall short when doing it in batch. When I arrived at each photo in my workflow I had to click re-analyze and at that point it got real close automatically,
I just tried it again on 25 photos and this time it worked and got real close on all of them ...and each of them show the steps I took in the History...
  • Enable Profile Corrections
  • Remove Chromatic Aberration
  • Constrain Crop
  • Upright Perspective
I must have been doing something wrong or perhaps had too many applications open when I tried that earler.
Thanks for your input!
jj
 
Joined
Jul 2, 2015
Messages
12,093
Location
Netherlands
Lightroom Experience
Power User
Check your synchronisation settings. You can sync the upright mode, but also the results. Make sure you do not sync the results.
 
Joined
Jul 2, 2015
Messages
12,093
Location
Netherlands
Lightroom Experience
Power User
To elaborate a bit more: if you use auto-sync, you don't get the sync dialog itself. The last settings are used. So select two images, do NOT set auto-sync, but press the Sync button. That will give you the dialog. Check that Upright Mode itself is selected, but the other options (called 'Upright Transformations' and 'Transformations', if I remember correctly) are not.
 
Status
Not open for further replies.
Top