Anyone using LR 6 licensed version with High Sierra Operating System

Joined
May 14, 2018
Messages
3
Lightroom Experience
Intermediate
Lightroom Version
5.x
#1
Lightroom Version
5.7
Operating System
Other (please note in thread)
I currently use LR 5.7, purchased outright, on my iMac with operating system (10.9.5) however my Mac is nearing the end of usage. Unfortunately I'm unable to update my iMac with the latest High Sierra operating system due to space/hard disk issues. I understand that LR 5.7 is NOT compatible with High Sierra. I will be purchasing a new iMac but I have no interest in subscribing to LR CC at this time. Can I migrate my current LR 5.7 catalog if I purchase the licensed version LR6 AND IS LR6 compatible with High Sierra?? Thank you in advance :)
 

clee01l

Senior Member
Staff member
Moderator
Lightroom Guru
Joined
Jun 20, 2009
Messages
13,656
Location
Bellaire, TX USA
Lightroom Experience
Power User
Lightroom Version
Classic 7
#2
Welcome to the forum.
LRv6.14 (the last update to LR6.x) is compatible with MacOS 10.13.x (High Sierra). Once installed, LR6 will copy and convert your LR5 catalog structure from your LR5 catalog file to the LR6 catalog structure in a duplicate LR6 catalog file. .
 
Joined
May 14, 2018
Messages
3
Lightroom Experience
Intermediate
Lightroom Version
5.x
#3
Thank you for the warm welcome and for your reply Cletus! I will proceed with the purchase of LR6 with confidence. I assume once I have purchased/downloaded LR6 it will prompt me to update to 6.14 ???
 

clee01l

Senior Member
Staff member
Moderator
Lightroom Guru
Joined
Jun 20, 2009
Messages
13,656
Location
Bellaire, TX USA
Lightroom Experience
Power User
Lightroom Version
Classic 7
#4
Thank you for the warm welcome and for your reply Cletus! I will proceed with the purchase of LR6 with confidence. I assume once I have purchased/downloaded LR6 it will prompt me to update to 6.14 ???
It may simply instal the update a part 2 of the install. I am not sure how Adobe currently is managing installed for non subscription products
 
Joined
Mar 15, 2018
Messages
6
Location
Scotland
Lightroom Experience
Intermediate
Lightroom Version
6.x / CC 2015.x
#7
Yes running LR6.14 on High Sierra on a Mid 2011 iMac no problems so far. LR 5.7 was crashing in develop mode with High Sierra and I think it was a video card/driver issue. However 6.14 is running fine so far. It has disabled graphics card acceleration. Don't find this a problem for my usage.
 
Top