• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.

Any filtering plugin able to use metadata fields ignored by LR ?

Joined
Jun 12, 2008
Messages
206
Location
Samoreau, France
Lightroom Experience
Power User
Lightroom Version
Classic
Hi,

Assuming I'd like to setup a filter based on the LensID or LensIDNumber fields, LR cannot help. It merely ignores these fields (and others). Is there any plugin that is able to do that ? I tried AnyFilter but that doesn't work for these fields.

Thanks in advance.

PS : I have found a workaround using exiftool (I move the contents of the LensID field to the Lens field) but this makes automatic recognition of the lens profile impossible. Setting the profile manually is not a big issue, though.
 
Joined
Jun 12, 2008
Messages
206
Location
Samoreau, France
Lightroom Experience
Power User
Lightroom Version
Classic
See my Search and Replace plugin.

Thanks. I tried but the LensID and LensIDNumber don't seem to be taken into account.

Actually, I'm investigating this for a colleague. He uses 2 different 50mm lenses but both lenses show the same string in the Lens field. They are correctly identified only by the LensID and LensIDNumber fields but LR doesn't use these fields for filtering. The only workaround that I found is to use exiftool to copy the contents of the LensID field to the Lens field. This works but makes automatic loading of the lens profile impossible.
 
Top