• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • The May 2019 Lightroom updates are now available. There's a brand new slider called Texture, available across the whole family of apps. Lightroom Classic includes a new tool called Flat Field Correction. Lightroom (cloud-based service) has lots of big improvements including cloud trash, invitation-only web galleries, improved chromatic aberration removal and more. The Missing FAQ and Edit Like a Pro eBooks are already updated for the changes. You'll also notice the CC's have disappeared off the end of the names, so we've updated the forum names to match.

"an unexpected end-of-file occurred" error message / correcting using Hexplorer

Birdbrain186

New Member
Joined
Apr 4, 2018
Messages
18
Location
Birmingham UK
Lightroom Experience
Intermediate
Lightroom Version
6.x / CC 2015.x
Lightroom Version
Lightroom version: 6.14 [ 1149743 ]
Operating System
Windows 10
I am occasionally getting the exclamation mark at top right of a few RAW thumbnails in Library mode (of LR 6.14), which leads to the message "Lightroom has encountered problems reading this photo - you will not be able to make adjustments to this photo."

If I try to open such files in Develop mode I then get the message "an unexpected end-of-file occurred" and indeed I am unable to open the file to make any adjustments, neither can I zoom into the preview image using Navigator.

Looking at a few Internet postings (outside this forum) suggests this occurs when the file has been corrupted during the Import process. A particular posting details a case where the person also had both a corrupted and an uncorrupted version of the same photo and by using "Hexplorer" software he established that the file had been truncated by just the final byte, and by using this software was able to "repair" the file which thereafter was editable in the normal way.

Please see following page for the full text of that posting:- -https://feedback.photoshop.com/photoshop_family/topics/_unexpected_end_of_file

I have downloaded the Hexplorer software but am struggling to understand how to make the necessary adjustment as detailed by the writer to "append 1A" to add back the missing file information.
I've been able to open the files in Hexplorer and get the two panel view displaying including the Hexadecimal view of the file data. I then have navigated with the cursor (highlighted in red) down to the bottom of that column presumably to the position of the "missing byte" ( Text at bottom of the boxes shows:- "Overwrite" & "Pos: 17a20ebh (24,781,035)" & "Byte: 0" & "Size: 24,781,035 bytes" & "Original")
So far so good but I'm then unclear how I'm supposed to enter the text "1A". I've tried using copy & paste - ie I copied the text (1A) and then tried to paste it by using (edit / paste external text / as hex numbers) - but all that happens is the red highlighted cursor moves one byte to the left and bottom text now shows:- ("Overwrite" & "Pos: 17a20eah (24,781,034)" & "Selection: 0 bytes0" & " Size: 24,781,035 bytes" & " Not saved") When I try to close the window I get a "save" option, which I've then selected but the photo still shows the black exclamation mark in Library mode and remains uneditable. (and reads exactly the same as before when reopening it in Hexplorer)

So evidently the process hasn't worked for me. However I only have however a very limited understanding of what I'm trying to do here and don't even know if the process should work with RAW files (Canon) anyway as the posting related rather to .nef (Nikon) and . arw (Sony) files, but I'm assuming a similar principle would apply to my RAW files, so perhaps I'm just not understanding sufficiently or carrying out the process correctly.

I'd be grateful therefore if anyone who has any greater understanding of using hexadecimal editors can clarify whether this process is likely to work for the problem I'm having and if so perhaps can also tell me where I'm going wrong.


Many thanks

Mike
 
Last edited:
Top