• Welcome to the Lightroom Queen Forums! We're a friendly bunch, so please feel free to register and join in the conversation. If you're not familiar with forums, you'll find step by step instructions on how to post your first thread under Help at the bottom of the page. You're also welcome to download our free Lightroom Quick Start eBooks and explore our other FAQ resources.
  • Stop struggling with Lightroom! There's no need to spend hours hunting for the answers to your Lightroom 6 questions. All the information you need is in Adobe Lightroom 6 - The Missing FAQ!

    To help you get started, there's a series of easy tutorials to guide you through a simple workflow. As you grow in confidence, the book switches to a conversational FAQ format, so you can quickly find answers to advanced questions. When you upgrade to subscription, there's also a Lightroom Classic version available.

A little problem in LR3 Library left panel

Status
Not open for further replies.
Joined
Feb 27, 2008
Messages
69
Location
Pori, Finland
Lightroom Experience
Advanced
Lightroom Version
Classic
Hello!
Have used LR3 for a while now (firs the beta versions and now the final) and like it much. Especially the lens correction was a long time on my wish list. Now I have noticed a little but somewhat annoying behaviour:
I have organized my library so that there is a big folder for every year since 2''1
and then several subfolders for subjects or themes. Now, always when I open LR,
it opens the year 2''8-folder in expanded mode, displaying all subfolders . No matter how
I close LR. And I cannot fix it anyhow. It's allways just the year 2''8.
As I said: no big problem but just irritates an old perfectionist a little bit.
Could anybody advise me What causes this an how to fix it?
 
Joined
Feb 1, 2010
Messages
13,136
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Odd....does this happen even when you are in Develop when you close down, i.e. does Lightroom then open up again in the Library module or Develop module? If you collapse the Folders pane so that NO folders are showing does the same thing happen?

If the answers to both the questions is YES, then I would agree that something is not quite right. My first concern would be to make sure that any edits, metadata changes etc. are being applied to the catalog properly. Have you checked that, i.e. make a change, close and restart and confirm the change is there? If that's OK, maybe simply resetting the preferences file could be tried.
 
Joined
Feb 27, 2008
Messages
69
Location
Pori, Finland
Lightroom Experience
Advanced
Lightroom Version
Classic
If I'm in Develop mode, LR opens up in Develop mode an all's OK, but if I close in library mode, no matter if the folders are collapsed or some folder open, LR always opens the year 2''8 (plus those folders that were open when closing).
I have also trashed the preference file, but it did not help.
 
Joined
Feb 1, 2010
Messages
13,136
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
OK, well it sounds as if everything is working as it should apart from this minor irritant. Is there any indication that there is a problem with any of the pictures in that 2''8 folder: any of the sub-folders showing a "?", or any of the individual pictures maybe?
 
Joined
Feb 27, 2008
Messages
69
Location
Pori, Finland
Lightroom Experience
Advanced
Lightroom Version
Classic
I have not noticed any problems with the pictures in that folder, although not much working with that old
pictures any more. But as you said: Minor irritant, so let it be. May be some day it solves itself (maybe next
update). Thank you Jim for your bother.
 
Joined
Feb 27, 2008
Messages
69
Location
Pori, Finland
Lightroom Experience
Advanced
Lightroom Version
Classic
One more little comment on this issue: I just removed the whole 2''8-folder after saveing metadata to files,
and then reimported it. Took some time (about 17''' pictures). Still don't know what caused it, but now the problem seems to have gone. :icon_lol:
 

ceroni

Member
Joined
Oct 16, 2009
Messages
38
Location
Brasil
Lightroom Experience
Intermediate
I've noticed this behaviour too. It was driving me mad.
After playing with the left panel for a while I found out the reason: Lr remembers any subfolder that is left open.
So, if you left a subfolder open, when Lr is run again the parent folder (and subfolder) is shown by default. Not very smart.
 
Joined
Feb 1, 2010
Messages
13,136
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
[quote author=ceroni link=topic=1''88.msg68388#msg68388 date=1276561163]
I've noticed this behaviour too. It was driving me mad.
After playing with the left panel for a while I found out the reason: Lr remembers any subfolder that is left open.
So, if you left a subfolder open, when Lr is run again the parent folder (and subfolder) is shown by default. Not very smart.
[/quote]

I don't think that was the OP's issue. On startup, LR restores the state as existed when you last closed down (assuming you open with the same catalog)....so if you were working on a picture in Develop when you closed down, that's were LR puts you when you next start up. Similarly if you are in Library working on a collection that's where LR puts you on startup.....and whatever panes or folders you had open or collapsed should be open or collapsed on startup. Interesting how people have different views about that, you think it isn't very smart, I think its perfectly logical! :)

The OP's problem, I think, is that his LR was not restoring the previous closed state on startup, but only in respect of one particular year folder, i.e. if the Folders panel was collapsed on closedown, on startup it would be open with the year 2''8 expanded to show all its sub-folders. To me, that seems different to your issue.
 
H

Humbaba

Guest
I am having the same problem, except it is not just one folder there are four which expand every time I start lightroom and every time I add a new folder or rename a folder. It started as one folder but the problem grew and grew and it is slowly driving me crazy.
 

pak

New Member
Joined
Dec 9, 2007
Messages
14
Location
Groningen, Netherlands
Same problem with me. Similar folder organization as Gronlund: a folder per year, inside each year many folders per date. E.g. 2'1'/2'1''521.
After collapsing all folders, after some fiddling around in LR, suddenly the 2''2 folder (ALWAYS 2''2) is expanded.
This happens reproducably when I'm moving folders. Initially I had the date folders (yyyymmdd) directly under the parent folder. Then I wanted to reorganize the folder structure into yyyy/yyyymmdd. When doing so, it works much quicker to have a folder selected that in not currently involved in the move operation, and having all yyyy folders collapsed while dragging the yyyynndd folders into them. This avoids redrawing the grid on each move. Now, when I had all folders collapsed, after each move, LR re-expanded the 2''2 folder.
I could not find anything special with this 2''2 folder.(LR 3.')
 
Joined
Feb 1, 2010
Messages
13,136
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Just noticed the same/similar problem on my desktop setup. My catalog there has several parent folders, and one of them was always expanded on restart even if I had collapsed it beforehand. After a few minutes of head-scratching the only thing I could see that was slightly unusual about this folder is that one of its sub-folders had a zero picture count (I used it for testing tethered capture). Removed the folder and that fixed the problem....on that catalog.

So then opened one of my laptop catalogs and found the same issue...but this time no sub-folder with a zero picture count! :rolleyes: So picked a sub-folder with a small number of pics and moved it using the Folders Panel to a different parent folder and again the problem was solved. I then moved it back, and the problem remained solved.

So it looks like it can be easily fixed, but still have no idea what triggers the issue in the first place.

Of course, not saying yours will be as simple a fix, but worth checking or noting for future reference.
 

pak

New Member
Joined
Dec 9, 2007
Messages
14
Location
Groningen, Netherlands
Triggered by TNG's response: I found no folders with zero picture counts. But I tried to randomly move some subfolders from the suspect "2''2" folder to another, then back. Now the problems has got worse:
Each time when I close LR after having collapsed all folders and a with a single picture in 2'1' selected, re-opening LR always expands the 2''2, 2''6 and 2''7 folders. The same folder and picture are nevertheless selected as were on closing LR.
I have the strong impression that my attempt to reorganize my folder structure as described in my previous post, has started this behaviour.

Optimizing the catalog or testing the integrity doesn't change anything.
 
H

Humbaba

Guest
My Problem is Fixed! Thanks TNG! I did not find a zero picture count in any of my offending folders but moving the folders worked. Let me try to describe this. Under My Pictures I have a folder called Friends There a several sub-folders for each friend I have pictures for and sub folders for each labeled by Year. The sub-folder for friend Jeff was an offending folder so I moved it up in the hierarchy so it shares a place in the hierarchy with the folder labeled Friends. Then I closed LR3, re-opened it, and moved Jeff back into the Friends folder where it was originally. After restarting LR3 the problem was solved. Does that make sense?
I think the most important part is to move the entire expanded folder up in the folder structure, not to move the sub-folders of the expanded folder arbitrarily.

Pak, I agree that the cause for this problem seems to be moving folders in LR3. I think that is when it started for me.
 

pak

New Member
Joined
Dec 9, 2007
Messages
14
Location
Groningen, Netherlands
Thanks Humbaba, you trick works. I did the same as you and it fixed the problem. I created a new top-level folder. Then one-by-one moved all problematic folders (those that continuously expand with no reason) to that new folder. Closed and reopened LR (probably not needed). Then moved the folders that were just moved, back to their original place. Since then these folders behave normally.

(It does of course not fix "the problem", it just repairs the symptoms. Does Adobe read this, or should this be posted also to a more official bug-report forum?)
 

Brad Snyder

Senior Member
Joined
Nov 20, 2007
Messages
6,293
Location
Port Deposit, Maryland USA
Lightroom Experience
Intermediate
No, this forum is not formally related to Adobe. There are a small handful of Adobe/Lr employees who are members here personally, but I believe their contributions are fairly sporadic. At present, I wouldn't be surprised if they were paying more attention to official Adobe communications channels.

That said, I believe very similar 'open folder' problems have been 'officially' reported. Wouldn't hurt to add extra voices, though.
 
Joined
Feb 1, 2010
Messages
13,136
Location
West Sussex, UK
Lightroom Experience
Advanced
Lightroom Version
Just did a bit of testing with the folders on my LR3 laptop system, and it seems to me that there has been a definite change from LR2.x to LR3 in the way that collapsed/expanded folders works.....and basically what it means is that if you want to keep your Folders Panel nice and small, perhaps with just the Parent Folder(s) normally showing, then you have to ensure that all folders and sub-folders in the hierarchy below the Parent Folder(s) are in collapsed state. If only one of them in the hierarchy is expanded prior to collapsing the Parent, then on restart LR3 will start up with the Parent expanded down to the level of the expanded sub-folder.

In case that doesn't make sense, here are a couple of snapshots to hopefully explain:

In the Step1 screenshot you see a small hierarchy of folders, several Parent Folders, one called Canon 5D MkII which is expanded to show several sub-folders, with one of them - 2''9 - also expanded to show the 2''9-1'-'2 sub-folder.

At that point I collapse the Parent Folder only as in the Step2 screenshot, then restart LR3 and lo and behold it opens with the same Folder position as in Step1.

If, however, I collapse the 2''9 folder - as per Step3 screenshot, THEN collapse the Parent, on restart I am presented with the desired position as per Step 2.

Have repeated this on my "main" desktop and confirm it operates the same way. Also can confirm that this does NOT happen on my LR2.6 setups.

So....is a bug or a design feature?
 

Karayuschij

Active Member
Joined
Jun 11, 2010
Messages
146
Location
Kiev, Ukraine
Lightroom Experience
Advanced
Lightroom Version
I have the same problem too.
I don't think that to re-export the whole catalog or to move the folders or anything else are valid solutions.
They can be temporary solutions, no more.
It is obviously a bug and has to be fixed asap.
 
M

MichaelAC

Guest
Thank you for all the hints ...

Had the same problem (my folder was "2''8" which always was expanded).
For me the "solutation" (strange to call such a trick a "solution") to move the folder 2''8 into another folder, and then move it back.

Question: is this already submitted as a bug?
 
R

rubicon

Guest
Hi, I know it sounds odd, but after having this problem for a while, I tried to bug it down. The suddenly I realized that if I deleted all ZBThumbnail.info files (from Canon Zoombrowser) in the folder having the issue, all my problems were gone. :D

Give it a try (as zoombrowser will regenerate the thumbnailfiles if needed)
 

HDProman

New Member
Joined
Sep 18, 2008
Messages
11
Location
San Bernardino, CA, USA
Lightroom Experience
Advanced
I am a little late to this party but please let me share my experiances with this problem...
I am having a minor issue with LR3x64 on my PC that has so far has defied explanation.
I will try to explain my issue as briefly as possible.
When starting LR certain folders in the folders panel always expand. I can collapse the folder tree and upon starting LR those same folders always expand even if they where collapsed when exiting and some folders that were collapsed when exiting will remain collapsed.
For example folder 2''8 will always expand no mater what state it was in when exiting.
Folder 2''7 will remember its state whether collapsed or expanded and always return to the same state.
I would like my folders panel view to always return to whatever state I left it in when LR is launched.
Is this possible, am I doing something wrong?

UPDATE:
I have several catalogs, one called Sports and another called Family. I opened my Family catalog and it does not have the issue I described in my previous question. My folders always open in whatever state they where in when I exited LR. My Sports catalog is having the issue with remembering the folder state.
I tried optimizing the catalog and I even deleted the preferences file without any change in this behavior.
I then exported the entire Sports catalog as a new catalog named Sports_2 and this new catalog now remembers the folders state and always returns exactly as when I exited LR.
I simply deleted my original Sports catalog and renamed Sports_2 to Sports and so far my issue is fixed, however I still don't understand what caused the issue to begin with.

UPDATE_2:
O.K I am totally frustrated now and I am thinking my problems is not anything I did but a LR bug.
In the new version of my Sports catalog I am making changes to this location:
D:>Photos>Sports>2''8>Basketball>Hurricanes'8 and the folder Hurricanes'8 contains subfolders, >'1-12, >'2-19, >'1-26, >'2-24, and >'3-'8 which are the different dates I shot this team.
Each date folder contains my original raw files and a sub folder names M1_8' for down sampled jpg files at quality 8'. These files where created use LR export and setting a lower resolution and quality of 8' to reduce size.
I am deleting old raw files so in each date folder I remove from disk all raw files and in each M1_8' folders I selected all the jpgs and moved them to the date folder where the raw files where. I then deleted all the M1_8' folders which are now empty. My folder structure in LR and Windows Explore match.
Now this Hurricanes'8 folder always expands when I launch the Sports catalog no matter what the state when closing LR.
A FIX:
In Windows Explore I rename Hurricanes'8 to Hurricanes'8-2 and LR now shows the question mark on the Hurricanes'8 folder as expected. I use find missing folder and located Hurricanes'8-2 and now LR is happy and the folder remembers what state, either expanded or collapsed when exiting LR and returns to that state as expected.
In LR I rename Hurricanes'8-2 back to Hurricanes'8 and everything is working as expected.
Any ideas what happened to cause this behavior and what could I do to prevent other folders from having this issue?
I tried many fixes and the renaming, find missing folder, change new name back to original seems to work and requires the least amount of effort.
I agree about deleting files, moving files and folders somehow triggers the problem and let's hope Adobe will address the problems in some update.
 
I am seeing an increasing number of people reporting this to me as well. I too think it is a bug, but I can not replicate it, which makes it really hard for me to report it as such. Can everyone who has had this happen report it here:

http://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

Thanks for the suggested workarounds.
 
Joined
Sep 29, 2007
Messages
22,967
Location
Isle of Wight, UK
Lightroom Experience
Power User
Lightroom Version
Cloud Service
Causing it on demand is definitely proving a problem, but loads of us have seen it. The 2 usual fixes are:

1. Alt-click / Opt-click on the parent folder disclosure triangle to collapse all subfolders and then restart LR and hopefully it'll sort it.

2. Select everything and export it to a new catalog. It leaves behind the dodgy bit of data that's opening the folders by mistake.
 
Status
Not open for further replies.
Top